aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages calcurse)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages ncurses))

(define-public calcurse
  (package
    (name "calcurse")
    (version "4.5.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://calcurse.org/files/calcurse-"
                           version ".tar.gz"))
       (sha256
        (base32 "0cgkd285x5pk62lmdx9fjxl46c5lj8wj2cqbxq7d99yb4il5fdjk"))))
    (build-system gnu-build-system)
    (inputs (list ncurses))
    (native-inputs (list tzdata-for-tests))
    (arguments
     ;; The ical tests all want to create a ".calcurse" directory, and may
     ;; fail with "cannot create directory '.calcurse': File exists" if run
     ;; concurently.
     `(#:configure-flags
       (list (string-append "--docdir=" (assoc-ref %outputs "out")
                            "/share/doc/" ,name "-" ,version))
       #:parallel-tests? #f
       ;; Since this tzdata is only used for tests and not referenced by the
       ;; built package, used the "fixed" obsolete version of tzdata and ensure
       ;; it does not sneak in to the closure.
       #:disallowed-references (,tzdata-for-tests)
       #:phases (modify-phases %standard-phases
                  (add-after 'unpack 'respect-docdir
                    ;; doc/Makefile disregards ./configure's --docdir option.
                    (lambda _
                      (substitute* "doc/Makefile.in"
                        (("(docdir =) .*" _ match)
                         (format #f "~a @docdir@\n" match)))
                      #t))
                  (add-before 'check 'check-setup
                    (lambda* (#:key inputs #:allow-other-keys)
                      (setenv "TZDIR"   ; for test/ical-007.sh
                              (search-input-directory inputs
                                                      "share/zoneinfo")))))))
    (home-page "https://www.calcurse.org")
    (synopsis "Text-based calendar and scheduling")
    (description
     "Calcurse is a text-based calendar and scheduling application.  It helps
keep track of events, appointments and everyday tasks.  A configurable
notification system reminds user of upcoming deadlines, and the curses based
interface can be customized to suit user needs.  All of the commands are
documented within an online help system.")
    (license bsd-2)))
/commit/.dir-locals.el?id=d52e16d3b68b4f5e748b4d6014d4a9c207266ade'>deduplication: Use 'dynamic-wind' when changing permissions of the parent....Ludovic Courtès 2020-06-16channels: 'latest-channel-instance' authenticates Git checkouts....Ludovic Courtès 2020-06-10database: separate transaction-handling and retry-handling....Caleb Ristvedt 2020-06-10database: ensure update-or-insert is run within a transaction...Caleb Ristvedt 2020-06-10database: rewrite query procedures in terms of with-statement....Caleb Ristvedt 2020-06-06ui: 'display-search-results' automatically invokes the pager....Ludovic Courtès 2020-06-05git-authenticate: Add tests....Ludovic Courtès 2020-05-16gexp: Add 'let-system'....Ludovic Courtès 2020-03-22store: Add 'with-build-handler'....Ludovic Courtès 2020-03-12gexp: Add 'with-parameters'....Ludovic Courtès 2019-11-29ui: Factorize 'with-profile-lock'....Ludovic Courtès 2019-11-19pull: Acquire a lock for the target profile....Ludovic Courtès 2019-09-23git: Add 'commit-difference'....Ludovic Courtès 2019-06-05syscalls: Add 'with-file-lock' macro....Ludovic Courtès 2019-05-27publish: Add support for lzip....Ludovic Courtès 2019-03-07database: Make 'register-items' transactional....Caleb Ristvedt 2019-01-11status: Add 'with-status-verbosity'....Ludovic Courtès 2018-10-19tests: Run 'guix pack' tests using the external store....Ludovic Courtès 2018-09-27Add (guix status) and use it for pretty colored output....Ludovic Courtès 2018-06-01Add (gnu store database)....Caleb Ristvedt 2018-06-01gexp: Add 'with-extensions'....Ludovic Courtès