aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages calcurse)
  #:use-module (guix packages)
  #:use-module (guix licenses)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (gnu packages ncurses))

(define-public calcurse
  (package
    (name "calcurse")
    (version "4.5.1")
    (source
     (origin
       (method url-fetch)
       (uri (string-append "https://calcurse.org/files/calcurse-"
                           version ".tar.gz"))
       (sha256
        (base32 "0cgkd285x5pk62lmdx9fjxl46c5lj8wj2cqbxq7d99yb4il5fdjk"))))
    (build-system gnu-build-system)
    (inputs (list ncurses))
    (native-inputs (list tzdata-for-tests))
    (arguments
     ;; The ical tests all want to create a ".calcurse" directory, and may
     ;; fail with "cannot create directory '.calcurse': File exists" if run
     ;; concurently.
     `(#:configure-flags
       (list (string-append "--docdir=" (assoc-ref %outputs "out")
                            "/share/doc/" ,name "-" ,version))
       #:parallel-tests? #f
       ;; Since this tzdata is only used for tests and not referenced by the
       ;; built package, used the "fixed" obsolete version of tzdata and ensure
       ;; it does not sneak in to the closure.
       #:disallowed-references (,tzdata-for-tests)
       #:phases (modify-phases %standard-phases
                  (add-after 'unpack 'respect-docdir
                    ;; doc/Makefile disregards ./configure's --docdir option.
                    (lambda _
                      (substitute* "doc/Makefile.in"
                        (("(docdir =) .*" _ match)
                         (format #f "~a @docdir@\n" match)))
                      #t))
                  (add-before 'check 'check-setup
                    (lambda* (#:key inputs #:allow-other-keys)
                      (setenv "TZDIR"   ; for test/ical-007.sh
                              (search-input-directory inputs
                                                      "share/zoneinfo")))))))
    (home-page "https://www.calcurse.org")
    (synopsis "Text-based calendar and scheduling")
    (description
     "Calcurse is a text-based calendar and scheduling application.  It helps
keep track of events, appointments and everyday tasks.  A configurable
notification system reminds user of upcoming deadlines, and the curses based
interface can be customized to suit user needs.  All of the commands are
documented within an online help system.")
    (license bsd-2)))
es/build-tools.scm (bear): New public variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fis Trivial 2018-03-22gnu: meson: Update to 0.45.1....* gnu/packages/build-tools.scm (meson): Update to 0.45.1. Marius Bakke 2018-03-18Merge branch 'master' into stagingMarius Bakke 2018-03-17gnu: Fix common unquote typos....It's easy to mistype ‘("foo" foo)’ as ‘("foo", foo)’ (which also works). Fix such typos for the proper edification of our young. * gnu/packages/android.scm: Move unquotes to their operands. * gnu/packages/bootloaders.scm: Likewise. * gnu/packages/build-tools.scm: Likewise. * gnu/packages/chemistry.scm: Likewise. * gnu/packages/compression.scm: Likewise. * gnu/packages/connman.scm: Likewise. * gnu/packages/django.scm: Likewise. * gnu/packages/emulators.scm: Likewise. * gnu/packages/engineering.scm: Likewise. * gnu/packages/file-systems.scm: Likewise. * gnu/packages/freedesktop.scm: Likewise. * gnu/packages/games.scm: Likewise. * gnu/packages/gimp.scm: Likewise. * gnu/packages/gl.scm: Likewise. * gnu/packages/gnome.scm: Likewise. * gnu/packages/graphics.scm: Likewise. * gnu/packages/haskell.scm: Likewise. * gnu/packages/irc.scm: Likewise. * gnu/packages/julia.scm: Likewise. * gnu/packages/kde-frameworks.scm: Likewise. * gnu/packages/linux.scm: Likewise. * gnu/packages/lua.scm: Likewise. * gnu/packages/mail.scm: Likewise. * gnu/packages/make-bootstrap.scm: Likewise. * gnu/packages/messaging.scm: Likewise. * gnu/packages/music.scm: Likewise. * gnu/packages/networking.scm: Likewise. * gnu/packages/ocaml.scm: Likewise. * gnu/packages/perl.scm: Likewise. * gnu/packages/python.scm: Likewise. * gnu/packages/python-web.scm: Likewise. * gnu/packages/qt.scm: Likewise. * gnu/packages/ratpoison.scm: Likewise. * gnu/packages/sdl.scm: Likewise. * gnu/packages/sml.scm: Likewise. * gnu/packages/terminals.scm: Likewise. * gnu/packages/text-editors.scm: Likewise. * gnu/packages/video.scm: Likewise. * gnu/packages/virtualization.scm: Likewise. * gnu/packages/vulkan.scm: Likewise. * gnu/packages/wget.scm: Likewise. * gnu/packages/wine.scm: Likewise. * gnu/packages/wm.scm: Likewise. * gnu/packages/xdisorg.scm: Likewise. * gnu/packages/xml.scm: Likewise. * gnu/packages/xorg.scm: Likewise. Tobias Geerinckx-Rice 2018-03-12gnu: meson: Update to 0.45.0....* gnu/packages/build-tools.scm (meson): Update to 0.45.0. [arguments]: Explicitly disable tests (they were skipped before). Marius Bakke 2018-03-12gnu: meson-for-build: Update to 0.44.0....* gnu/packages/build-tools.scm (meson-for-build)[version]: Remove field. [source]: Inherit from MESON. Marius Bakke 2018-03-12gnu: meson: Don't wrap the meson executable....* gnu/packages/build-tools.scm (meson)[arguments]: Delete WRAP-PHASE. Marius Bakke 2018-03-07gnu: meson: Mark up description....* gnu/packages/build-tools.scm (meson)[description]: Use @dfn. Tobias Geerinckx-Rice 2017-12-12gnu: meson: Update to 0.44.0....* gnu/packages/build-tools.scm (meson): Update to 0.44.0 Tobias Geerinckx-Rice 2017-10-13gnu: meson: Update to 0.43.0....* gnu/packages/build-tools.scm (meson): Update to 0.43.0. Ricardo Wurmus 2017-10-09gnu: meson: Update to 0.42.1....* gnu/packages/build-tools.scm (meson, meson-for-build): Update to 0.42.1. Tobias Geerinckx-Rice 2017-09-16gnu: Add meson-for-build....* gnu/packages/build-tools.scm (meson-for-build): New variable. * gnu/packages/patches/meson-for-build-rpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Peter Mikkelsen 2017-09-16gnu: meson: Update to 0.42.0....* gnu/packages/build-tools.scm (meson): Update to 0.42.0. [propagated-inputs]: Add python. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Peter Mikkelsen 2017-07-20gnu: Add premake4....* gnu/packages/build-tools.scm (premake4): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Oleg Pykhalov 2017-07-19gnu: meson: Update to 0.41.1....* gnu/packages/build-tools.scm (meson) Update to 0.41.1. Tobias Geerinckx-Rice 2017-05-07gnu: meson: Update to 0.40.1....* gnu/packages/build-tools.scm (meson): Update to 0.40.1. Tobias Geerinckx-Rice 2017-04-20gnu: Add Meson....* gnu/packages/build-tools.scm (meson): New variables. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Corentin Bocquillon 2017-04-13gnu: Add bam....* gnu/packages/build-tools.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Ricardo Wurmus