aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages bison)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages m4)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages flex)
  #:use-module (srfi srfi-1))

(define-public bison
  (package
    (name "bison")
    (version "3.8.2")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/bison/bison-"
                          version ".tar.xz"))
      (sha256
       (base32
        "1wjvbbzrr16k1jlby3l436an3kvv492h08arbnf0gwgprha05flv"))))
    (build-system gnu-build-system)
    (arguments
     '(;; Building in parallel on many-core systems may cause an error such as
       ;; "mv: cannot stat 'examples/c/reccalc/scan.stamp.tmp': No such file or
       ;; directory".  See <https://bugs.gnu.org/36238>.
       #:parallel-build? #f
       ;; Similarly, when building tests in parallel, Make may produce this error:
       ;; "./examples/c/reccalc/scan.l:13:10: fatal error: parse.h: No such file
       ;; or directory".  Full log in <https://bugs.gnu.org/36238>.
       #:parallel-tests? #f))
    (native-inputs (list perl
                         ;; m4 is not present in PATH when cross-building.
                         m4))
    (inputs (list flex))
    (propagated-inputs (list m4))
    (home-page "https://www.gnu.org/software/bison/")
    (synopsis "Yacc-compatible parser generator")
    (description
     "GNU Bison is a general-purpose parser generator.  It can build a
deterministic or generalized LR parser from an annotated, context-free
grammar.  It is versatile enough to have many applications, from parsers for
simple tools through complex programming languages.

Bison also provides an implementation of @command{yacc}, as specified by POSIX.")
    (license gpl3+)))

(define-public bison-3.0
  (package
    (inherit bison)
    (version "3.0.5")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/bison/bison-"
                          version ".tar.xz"))
      (sha256
       (base32
        "0f7kjygrckkx8vas2nm673592jif0a9mw5g8207f6hj6h4pfyp07"))))))
8d522379e4957f91c80b4af8fc073c70369adf8'>gnu: font-chiron-sung-hk: Update to 1.008....Hilton Chain 2023-05-24gnu: font-gnu-unifont: Remove more pre-generated files....Efraim Flashner 2023-05-15gnu: Add font-recursive....Bassam Saeed 2023-05-15gnu: Add font-scientifica....Ahmad Draidi 2023-05-14gnu: Add Iosevka comfy font....Arnaud Lechevallier 2023-05-14gnu: Add font-spleen....Ahmad Draidi 2023-04-22Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-04-22gnu: font-amiri: Update to 1.000....Greg Hogan 2023-04-19gnu: font-meera-inimai: Use gexps and remove labels....Maxim Cournoyer 2023-04-19gnu: python-fonttools-full: Rename to python-fonttools....Maxim Cournoyer 2023-04-14Merge branch 'master' into core-updates....Maxim Cournoyer 2023-04-14gnu: font-abattis-cantarell: Update to 0.303-0.e049149....Maxim Cournoyer 2023-04-12gnu: font-abattis-cantarell: Update to 0.303-0.e049149....Maxim Cournoyer 2023-04-12gnu: Add font-chivo....Nicolas Graves 2023-04-02gnu: Add font-chivo....Nicolas Graves 2023-03-26gnu: font-sil-charis: Update to 6.2.0....Stefan Baums 2023-03-26gnu: font-sil-andika: Update to 6.2.0....Stefan Baums 2023-03-26gnu: font-sil-gentium: Update to 6.2.0....Stefan Baums 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-13gnu: Add font-iosevka-ss09....Paul A. Patience 2023-03-13gnu: Add font-iosevka-ss08....Paul A. Patience 2023-03-13gnu: font-iosevka: Update to 20.0.0....Paul A. Patience 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines 2023-03-01gnu: font-google-noto-emoji: Install correct license file....Simon South 2023-02-27gnu: Add font-microsoft-cascadia....Jake Leporte 2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice 2023-02-07gnu: font-lxgw-wenkai-tc: Update to 0.932....Hilton Chain 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates...Efraim Flashner 2023-01-30gnu: font-sarasa-gothic: Update to 0.39.0....Hilton Chain 2023-01-30gnu: font-lxgw-wenkai-tc: Update to 0.931....Hilton Chain 2023-01-30gnu: font-lxgw-wenkai: Update to 1.250....Hilton Chain 2023-01-30gnu: Add font-carlito....Trev 2023-01-28gnu: Add font-google-noto-emoji....Fredrik Salomonsson