aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2016, 2017, 2020, 2021, 2023 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2019, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages bdw-gc)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix gexp)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages hurd))

(define-public libgc
  (package
   (name "libgc")
   (version "8.2.4")
   (source (origin
            (method url-fetch)
            (uri (list (string-append "https://github.com/ivmai/bdwgc/releases"
                                      "/download/v" version
                                      "/gc-" version ".tar.gz")
                       (string-append "https://www.hboehm.info/gc/gc_source"
                                      "/gc-" version ".tar.gz")))
            (sha256
             (base32
              "1hlgqkg9arc8sqf7wamvzmp3shb3np5z0h5v0qqksh3pw3dkq39x"))))
   (build-system gnu-build-system)
   (arguments
    (append
     (list
     #:configure-flags
     #~(list
        ;; Install gc_cpp.h et al.
        "--enable-cplusplus"

        ;; In GNU/Hurd systems during the 'check' phase,
        ;; there is a deadlock caused by the 'gctest' test.
        ;; To disable the error set "--disable-gcj-support"
        ;; to configure script. See bug report and discussion:
        ;; <https://lists.opendylan.org/pipermail/bdwgc/2017-April/006275.html>
        ;; <https://lists.gnu.org/archive/html/bug-hurd/2017-01/msg00008.html>
        #$@(if (target-hurd? (or (%current-system)
                                 (%current-target-system)))
               #~("--disable-gcj-support")
               #~())))
     (cond
       ((target-ppc64le?)
        (list #:make-flags
              ;; This is a known workaround upstream.
              ;; https://github.com/ivmai/bdwgc/issues/479
              #~(list "CFLAGS_EXTRA=-DNO_SOFT_VDB")))
       ((target-ppc32?)
        (list #:make-flags
              ;; Similar to above.
              #~(list "CFLAGS_EXTRA=-DNO_MPROTECT_VDB")))
       (else '()))))
   (native-inputs (list pkg-config))
   (propagated-inputs
    (if (%current-target-system)
        ;; The build system refuses to check for compiler intrinsics when
        ;; cross-compiling, and demands using libatomic-ops instead.
        (list libatomic-ops)
        '()))
   (outputs '("out" "debug"))
   (properties
    '((release-monitoring-url . "https://www.hboehm.info/gc/gc_source/")
      (upstream-name . "gc")))
   (synopsis "The Boehm-Demers-Weiser conservative garbage collector
for C and C++")
   (description
    "The Boehm-Demers-Weiser conservative garbage collector can be used
as a garbage collecting replacement for C malloc or C++ new.  It allows
you to allocate memory basically as you normally would, without
explicitly deallocating memory that is no longer useful.  The collector
automatically recycles memory when it determines that it can no longer
be otherwise accessed.

The collector is also used by a number of programming language
implementations that either use C as intermediate code, want to
facilitate easier interoperation with C libraries, or just prefer the
simple collector interface.

Alternatively, the garbage collector may be used as a leak detector for
C or C++ programs, though that is not its primary goal.")
   (home-page "https://www.hboehm.info/gc/")

   (license (x11-style (string-append home-page "license.txt")))))

;; TODO: Add a static output in libgc in the next rebuild cycle.
(define-public libgc/static-libs
  (package/inherit
   libgc
   (arguments
    (substitute-keyword-arguments (package-arguments libgc)
      ((#:configure-flags flags #~'())
       #~(cons "--enable-static" #$flags))))

   (properties '((hidden? . #t)))))

(define-public libgc-7
  (package
   (inherit libgc)
   (version "7.6.12")
   (source (origin
             (method url-fetch)
             (uri (string-append "https://github.com/ivmai/bdwgc/releases"
                                 "/download/v" version "/gc-" version ".tar.gz"))
             (sha256
              (base32
               "10jhhi79d5brwlsyhwgpnrmc8nhlf7aan2lk9xhgihk5jc6srbvc"))))
   (propagated-inputs (list libatomic-ops))))

(define-public libgc/back-pointers
  (package/inherit
    libgc
    (name "libgc-back-pointers")
    (arguments
     (substitute-keyword-arguments (package-arguments libgc)
       ((#:make-flags _ #~'())
        #~(list "CPPFLAGS=-DKEEP_BACK_PTRS=1"))))
    (synopsis "The BDW garbage collector, with back-pointer tracking")))

(define-public libatomic-ops
  (package
    (name "libatomic-ops")
    (version "7.6.12")
    (source (origin
              (method url-fetch)
              (uri (string-append
                    "https://github.com/ivmai/libatomic_ops/releases/download/v"
                    version "/libatomic_ops-" version ".tar.gz"))
              (sha256
               (base32
                "0glzah695wsf6c27hs5wwlw4mnq1vfivdshz1rb8pq7w4mp5dazh"))))
    (build-system gnu-build-system)
    (outputs '("out" "debug"))
    (synopsis "Accessing hardware atomic memory update operations")
    (description
     "This C library provides semi-portable access to hardware-provided atomic
memory update operations on a number of architectures.  These might allow you to
write code that does more interesting things in signal handlers, write
lock-free code, experiment with thread programming paradigms, etc.")
    (home-page "https://github.com/ivmai/libatomic_ops/")

    ;; Some source files are X11-style, others are GPLv2+.
    (license gpl2+)))
727'>gnu: crm114: Use emacs-build-system install phase....* gnu/packages/mail.scm (crm114)[arguments]: Install the crm114 emacs mode using the install phase from emacs-build-system, instead of in the custom pre-install phase. Run the make-autoloads phase after this new install-emacs-mode phase. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at> Arun Isaac 2021-05-04gnu: Exim: Update to 4.94.2 [security fixes]....Fixes CVE-2020-{27216,28007,28008,28009,28010,28011,28012,28013,28014,28015, 28016,28017,28018,28019,28020,28021,28022,28023,28024,28025,28026}. See the upstream security advisory for more information: https://exim.org/static/doc/security/CVE-2020-qualys/21nails.txt * gnu/packages/mail.scm (exim): Update to 4.94.2. Leo Famulari 2021-05-03gnu: public-inbox: Update to 1.6.1....* gnu/packages/mail.scm (public-inbox)[version]: Update to 1.6.1. [inputs]: Add optional dependencies. ‘perl-filesys-notify-simple’ has been superseded by ‘perl-linux-inotify2’ by upstream. [synopsis]: Capitalize “git”. [description]: Likewise. Mention IMAP support. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Xinglu Chen 2021-05-01gnu: notmuch: Adjust to changes in emacs-build-system....* gnu/packages/mail.scm (notmuch)[configure]: Use elpa-directory. Leo Prikler 2021-05-01gnu: mailcap: Update to 2.1.53....* gnu/packages/mail.scm (mailcap): Update to 2.1.53. Tobias Geerinckx-Rice 2021-04-27gnu: alpine: Update to 2.24.1....* gnu/packages/mail.scm (alpine): Update to 2.24.1. Tobias Geerinckx-Rice 2021-04-27gnu: fetchmail: Update to 6.4.19....* gnu/packages/mail.scm (fetchmail): Update to 6.4.19. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Xinglu Chen 2021-04-21gnu: Add crm114....* gnu/packages/mail.scm (crm114): New variable. Arun Isaac 2021-04-11gnu: Add abook....* gnu/packages/mail.scm (abook): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Alexandru-Sergiu Marton 2021-04-06gnu: Add opensmtpd-filter-rspamd....* gnu/packages/mail.scm (opensmtpd-filter-rspamd): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Alexey Abramov 2021-03-31gnu: mumi: Update to 0.0.1-5.9f070bd....* gnu/packages/mail.scm (mumi): Update to 0.0.1-5.9f070bd. Ricardo Wurmus 2021-03-31gnu: mumi: Update to 0.0.1-4.887471f....* gnu/packages/mail.scm (mumi): Update to 0.0.1-4.887471f. Ricardo Wurmus 2021-03-29gnu: fetchmail: Update to 6.4.18....* gnu/packages/mail.scm (fetchmail): Update to 6.4.18. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Xinglu Chen 2021-03-29gnu: urlscan: Update to 0.9.6....* gnu/packages/mail.scm (urlscan): Update to 0.9.6. Efraim Flashner 2021-03-29gnu: neomutt: Update to 20210205....* gnu/packages/mail.scm (neomutt): Update to 20210205. Tobias Geerinckx-Rice 2021-03-29gnu: mpop: Update to 1.4.13....* gnu/packages/mail.scm (mpop): Update to 1.4.13. Tobias Geerinckx-Rice 2021-03-25gnu: Add go-gitlab.com-shackra-goimapnotify....* gnu/packages/mail.scm (go-gitlab.com-shackra-goimapnotify): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Benoit Joly 2021-03-21gnu: balsa: Update to 2.6.2....* gnu/packages/mail.scm (balsa): Update to 2.6.2. [inputs]: Add libassuan. Upgrade gtksourceview. Tobias Geerinckx-Rice 2021-03-21gnu: msmtp: Update to 1.8.15....* gnu/packages/mail.scm (msmtp): Update to 1.8.15. Tobias Geerinckx-Rice 2021-03-17gnu: Use autoconf instead of autoconf-wrapper when possible....This should reduce confusion on when to use the "autoconf" package and when to use "autoconf-wrapper" instead in package definitions. Fixes <https://bugs.gnu.org/46564>. * gnu/packages/autotools.scm (autoconf-wrapper): advise to use the "autoconf" package instead where possible. * gnu/packages/game-development.scm (tsukundere)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/gimp.scm (glimpse)[native-inputs]: likewise. (gimp-resynthesizer)[native-inputs]: add comment on why "autoconf-wrapper" is used. * gnu/packages/gnunet.scm (gnunet)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/gnupg.scm (signing-party)[native-inputs]: add comment on why "autoconf-wrapper" is used. * gnu/packages/guile-xyz.scm (guile-bash,guile-filesystem,guile-ics,guile-udev)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/libevent.scm (libuv)[native-inputs]: indicates "autoconf-wrapper" needs to be replaced with "autoconf" on core-updates. * gnu/packages/logging.scm (glog)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/mail.scm (libetpan)[native-inputs]: likewise. * gnu/packages/mate.scm (mate-icon-theme-faenza)[native-inputs]: add comment on why "autoconf-wrapper" is used. (mate-screensaver)[native-inputs]: use "autoconf" instead of "autoconf-wrapper". * gnu/packages/package-management.scm (guix)[native-inputs]: likewise. * gnu/packages/sawfish.scm (librep)[native-inputs]: likewise. * gnu/packages/video.scm (motion)[native-inputs]: likewise. * gnu/packages/zile.scm (zile)[native-inputs]: likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-03-13gnu: Add l2md....* gnu/packages/mail.scm (l2md): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Xinglu Chen 2021-03-11gnu: mutt: Update to 2.0.6....* gnu/packages/mail.scm (mutt): Update to 2.0.6. Tobias Geerinckx-Rice 2021-03-08gnu: fetchmail: Update to 6.4.17....* gnu/packages/mail.scm (fetchmail): Update to 6.4.17. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Xinglu Chen 2021-03-06gnu: getmail: Update to 5.15....* gnu/packages/mail.scm (getmail): Update to 5.15. Tobias Geerinckx-Rice 2021-03-06gnu: ytnef: Fix CVE-2021-3403 and CVE-2021-3404....* gnu/packages/patches/ytnef-CVE-2021-3403.patch, gnu/packages/patches/ytnef-CVE-2021-3404.patch: New patches. * gnu/local.mk (dist_patch_DATA): Register them. * gnu/packages/mail.scm (ytnef): Apply them. Léo Le Bouter 2021-03-04gnu: dovecot-pigeonhole: Update to 0.5.14....* gnu/packages/mail.scm (dovecot-pigeonhole): Update to 0.5.14. Tobias Geerinckx-Rice 2021-03-04gnu: dovecot: Update to 2.3.14....* gnu/packages/mail.scm (dovecot): Update to 2.3.14. Tobias Geerinckx-Rice 2021-03-04gnu: isync: Update to 1.4.1....* gnu/packages/mail.scm (isync): Update to 1.4.1. Tobias Geerinckx-Rice 2021-03-04gnu: fetchmail: Update to 6.4.16....* gnu/packages/mail.scm (fetchmail): Update to 6.4.16. Tobias Geerinckx-Rice 2021-02-24gnu: notmuch: Update to 0.31.4....* gnu/packages/mail.scm (notmuch): Update to 0.31.4. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Xinglu Chen 2021-02-22gnu: isync: Update to 1.3.5 [fixes CVE-2021-20247]....* gnu/packages/mail.scm (isync): Update to 1.3.5. Leo Famulari 2021-02-07gnu: mu: Update to 1.4.15....* gnu/packages/mail.scm (mu): Update to 1.4.15. Tobias Geerinckx-Rice