aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages augeas)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix gexp)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix git-download)
  #:use-module (guix utils)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system pyproject)
  #:use-module (gnu packages)
  #:use-module (gnu packages check)
  #:use-module (gnu packages libffi)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages xml))

(define-public augeas
  (package
    (name "augeas")
    (version "1.14.1")
    (source (origin
              ;; XXX: Project release has moved to GitHub which has
              ;;      pre-generated "configure" script that allows to simplify
              ;;      the package definition. Try to completely build from
              ;;      source, glibc comes as git submodule.
              (method url-fetch)
              (uri
               (string-append
                "https://github.com/hercules-team/augeas/releases/download/"
                "release-" version
                "/augeas-" version ".tar.gz"))
              (sha256
               (base32
                "1zzdp5bwnszza5q6cjw66hkicay8b49n5pda7cbcgfg4hbbzv2rn"))))
    (build-system gnu-build-system)
    (propagated-inputs
     (list libxml2))
    (native-inputs
     (list readline pkg-config))
    (home-page "https://augeas.net")
    (synopsis "Edit configuration files programmatically")
    (description
     "Augeas is a library and command line tool for programmatically editing
configuration files in a controlled manner.  Augeas exposes a tree of all
configuration settings and a simple local API for manipulating the tree.
Augeas then modifies underlying configuration files according to the changes
that have been made to the tree; it does as little modeling of configurations
as possible, and focuses exclusivley on transforming the tree-oriented syntax
of its public API to the myriad syntaxes of individual configuration files.")
    (license license:lgpl2.1+)))

(define-public python-augeas
  (package
    (name "python-augeas")
    (version "1.2.0")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             (url "https://github.com/hercules-team/python-augeas")
             (commit (string-append "v" version))))
       (file-name (git-file-name name version))
       (sha256
        (base32 "1l17gl23f5naram1jaab7gjr9bhjdj97fd9sydvs7cmpns91rbrf"))))
    (build-system pyproject-build-system)
    (native-inputs
     (list python-pytest pkg-config))
    (propagated-inputs
     (list python-cffi))
    (inputs
     (list augeas libxml2))
    (home-page "https://github.com/hercules-team/python-augeas")
    (synopsis "Python bindings for Augeas")
    (description "Pure Python bindings for @url{https://augeas.net, Augeas}.")
    (license license:lgpl2.1+)))
='/guix/commit/gnu/packages/disk.scm?id=90f0791038fa51dcbff48e4f393449c7d6c458f7'>gnu: ndctl: Gexp arguments....* gnu/packages/disk.scm (ndctl)[arguments]: Rewrite as a keyword/gexp list and move to the conventional location. Tobias Geerinckx-Rice 2021-12-25gnu: ndctl: Update to 72....* gnu/packages/disk.scm (ndctl): Update to 72. [arguments]: Add a new 'fix-include phase. Don't explicitly return #t from phases. [inputs]: Add iniparser. Tobias Geerinckx-Rice 2021-12-17gnu: memkind: Update to 1.12.0....* gnu/packages/disk.scm (memkind): Update to 1.12.0. [arguments]: Don't explicitly return #t from phases. Tobias Geerinckx-Rice 2021-12-16gnu: Add qdirstat....* gnu/packages/disk.scm (qdirstat): New variable Signed-off-by: Leo Famulari <leo@famulari.name> terramorpha 2021-12-13gnu: Simplify package inputs....This commit was obtained by running: ./pre-inst-env guix style without any additional argument. Ludovic Courtès 2021-12-10gnu: dosfstools: Fix cross-compilation....Reported by Florian Hoertlehner. * gnu/packages/disk.scm (dosfstools)[arguments]: Correctly refer to the build output. Use cc-for-target. Efraim Flashner 2021-11-11gnu: libblockdev: Update to 2.26....* gnu/packages/disk.scm (libblockdev): Update to 2.26. [source]: Remove patches field. [inputs]: Add xfsprogs. * gnu/packages/patches/libblockdev-glib-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it. Maxim Cournoyer 2021-11-08Merge remote-tracking branch 'origin/master' into core-updates-frozenEfraim Flashner 2021-11-03gnu: libblockdev: Update to 2.26....* gnu/packages/disk.scm (libblockdev): Update to 2.26. [source]: Remove patch. * gnu/packages/patches/libblockdev-glib-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Tobias Geerinckx-Rice 2021-10-18Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-10-14gnu: lf: Update to 25...* gnu/packages/disk.scm (lf): Update to 25 Signed-off-by: Ludovic Courtès <ludo@gnu.org> Chadwain Holness 2021-10-02gnu: Update gtkmm to 4.2.0, add gtkmm@3, and adjust gtkmm@2....* gnu/packages/gtk.scm (gtkmm)[version]: Update to 4.2.0. [arguments](meson): New argument. [native-inputs]: Add glib:bin. [propagated-inputs]: Replace gtk+ with gtk. (gtkmm-3): New variable. (gtkmm-2)[arguments]: Strip certain inherited arguments. * gnu/packages/animation.scm (synfigstudio)[inputs]: Switch to gtkmm-3. * gnu/packages/astronomy.scm (stackistry)[inputs]: Ditto. * gnu/packages/audio.scm (guitarix)[inputs]: Ditto. * gnu/packages/disk.scm (parted)[inputs]: Ditto. * gnu/packages/gnome.scm (gnome-system-monitor)[inputs]: Ditto. (workrave)[inputs]: Ditto. (gnote)[inputs]: Ditto. * gnu/packages/gobby.scm (gobby)[inputs]: Ditto. * gnu/packages/inkscape.scm (inkscape)[inputs]: Ditto. * gnu/packages/mail.scm (astroid)[inputs]: Ditto. * gnu/packages/mate.scm (mate-system-monitor)[inputs]: Ditto. * gnu/packages/music.scm (tascam-gtk)[inputs]: Ditto. * gnu/packages/photo.scm (rawtherapee)[inputs]: Ditto. * gnu/packages/pulseaudio.scm (pavucontrol)[inputs]: Ditto. (paprefs)[inputs]: Ditto. * gnu/packages/text-editors.scm (jucipp)[inputs]: Ditto. * gnu/packages/wm.scm (waybar)[inputs]: Ditto. Raghav Gururajan 2021-09-04gnu: gparted: Update to 1.3.1....* gnu/packages/disk.scm (gparted): Update to 1.3.1. Tobias Geerinckx-Rice 2021-07-27gnu: duperemove: Update to 0.11.3....* gnu/packages/disk.scm (duperemove): Update to 0.11.3. Leo Famulari 2021-07-29gnu: web: Move libyaml and libcyaml to (gnu packages serialization)....Files to be adjusted were searched with the following command: $ git ls-files | xargs grep -l -E ',libc?yaml' | \ xargs grep -L '(gnu packages serialization)' * gnu/packages/web.scm (libyaml, libyaml+static, libcyaml): Move to... * gnu/packages/serialization.scm: ... here. Maxim Cournoyer 2021-06-19gnu: Add duc....* gnu/packages/disk.scm (duc): New variable. Brice Waegeneire 2021-06-10gnu: gptfdisk: Update to 1.0.8....* gnu/packages/disk.scm (gptfdisk): Update to 1.0.8. Tobias Geerinckx-Rice 2021-06-05gnu: gparted: Update to 1.3.0....* gnu/packages/disk.scm (gparted): Update to 1.3.0. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Brendan Tildesley 2021-05-23gnu: hddtemp: Update to 0.4.3....* gnu/packages/disk.scm (hddtemp): Update to 0.4.3. [source, home-page]: Use a maintained fork/continuation. [arguments]: Add a new 'delete-autogen.sh phase. Adjust the 'install-db phase to install the bundled hddtemp.db. [inputs]: Remove old hddtemp.db. [native-inputs]: Add autoconf, automake, and gettext. f hddtemp Tobias Geerinckx-Rice 2021-05-22gnu: libblockdev: Prepare for GLib 2.58....* gnu/packages/patches/libblockdev-glib-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/disk.scm (libblockdev)[source](patches): New field. Marius Bakke 2021-05-13gnu: xfe: Update to 1.44 and adjust potfiles....* gnu/packages/disk.scm (xfe)[version]: Update to 1.44. [phases](patch-potfiles): New phase. Raghav Gururajan 2021-05-13gnu: Add bmaptools....* gnu/packages/disk.scm (bmaptools): New variable. Mathieu Othacehe 2021-04-28gnu: Add mmc-utils....* gnu/packages/disk.scm (mmc-utils): New variable. Leo Famulari 2021-04-23gnu: sdparm: Update to 1.12....* gnu/packages/disk.scm (sdparm): Update to 1.12. Tobias Geerinckx-Rice 2021-04-10gnu: gpart: Fix typo in description....* gnu/packages/disk.scm (gpart)[description]: Fix my own typo. Tobias Geerinckx-Rice 2021-03-27gnu: Add gpart....* gnu/packages/disk.scm (gpart): New public variable. Tobias Geerinckx-Rice 2021-03-27gnu: gptfdisk: Update to 1.0.7....* gnu/packages/disk.scm (gptfdisk): Update to 1.0.7. Tobias Geerinckx-Rice 2021-03-24gnu: ddrescue: Support cross compiling....* gnu/packages/disk.scm (ddrescue)[arguments]: Add configure-flag to fix cross compiling. Efraim Flashner