aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2013, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages attr)
  #:use-module (guix licenses)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages gettext)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils))

(define-public attr
  (package
    (name "attr")
    (version "2.5.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://savannah/attr/attr-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "1y6sibbkrcjygv8naadnsg6xmsqwfh6cwrqk01l0v2i5kfacdqds"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         ,@(if (target-hurd?)
               `((add-before 'configure 'skip-linux-syscalls
                   (lambda _
                     ;; Starting from 2.5.1, libattr includes Linux-specific
                     ;; calls to syscall(2).  Comment them out for GNU/Hurd
                     ;; and instead use the glibc-provided wrappers.
                     (substitute* "Makefile.in"
                       (("libattr/syscalls\\.c") "")
                       (("\tlibattr/la-syscalls\\.lo") "")
                       (("-Wl,[[:graph:]]+/libattr\\.lds") "")))))
               '())
         (replace 'check
           (lambda* (#:key target #:allow-other-keys)
             ;; Use the right shell.
             (substitute* "test/run"
               (("/bin/sh")
                (which "sh")))

             ;; When building natively, run the tests.
             ;;
             ;; Note that we use system* and unconditionally return #t here
             ;; to ignore the test result, because the tests will fail when
             ;; the build is performed on a file system without support for
             ;; extended attributes, and we wish to allow Guix to be built
             ;; on such systems.
             (unless target
               (system* "make" "tests" "-C" "test")))))))
    (inputs
     ;; Perl is needed to run tests; remove it from cross builds.
     (if (%current-target-system)
         '()
         `(("perl" ,perl))))
    (native-inputs
     `(("gettext" ,gettext-minimal)))

    (home-page "https://savannah.nongnu.org/projects/attr/")
    (synopsis "Library and tools for manipulating extended attributes")
    (description
     "Portable library and tools for manipulating extended attributes.")
    (license lgpl2.1+)))
udovic Courtès 2023-05-06gnu: guix-data-service: Update to 0.0.1-40.3734a85...Christopher Baines 2023-04-30gnu: mod-wsgi: Make sure not to keep a store reference to HTTPD....Leo Famulari 2023-04-30gnu: httpd: Update to 2.4.57 [security fixes]....Leo Famulari 2023-04-27gnu: libwebsockets: Update to 4.3.2....Ricardo Wurmus 2023-04-26gnu: rapidjson: Update to 1.1.0-1.949c771....Ricardo Wurmus 2023-04-22Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-04-22gnu: Add binaryen....Ricardo Wurmus 2023-04-22gnu: wabt: Update to 1.0.32....Ricardo Wurmus 2023-04-14Merge branch 'master' into core-updates....Maxim Cournoyer 2023-04-14gnu: perl-io-socket-ssl: Update to 2.081....Bruno Victal 2023-04-14gnu: perl-io-socket-ssl: Update to 2.075....Marius Bakke 2023-04-14gnu: perl-http-daemon: Update to 6.14....Marius Bakke 2023-04-14gnu: perl-http-message: Update to 6.37....Marius Bakke 2023-04-12gnu: Add nntpit....James 2023-04-02gnu: Add nntpit....James 2023-03-31gnu: Replace all uses of atk by at-spi2-core....Josselin Poiret 2023-03-30gnu: perl-io-socket-ssl: Update to 2.081....Bruno Victal 2023-03-23Merge remote-tracking branch 'origin/master' into staging....Maxim Cournoyer 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-18gnu: Add tissue....Arun Isaac 2023-03-18gnu: python-feedparser: Add Python >=3.9 compatibility....Lars-Dominik Braun 2023-03-16gnu: cat-avatar-generator: Update to 1-1.9360ea3....Evgeny Pisemsky 2023-03-11gnu: python-feedparser: Update to 6.0.10....Andreas Enge 2023-03-10gnu: Add kiln....Nikolay Korotkiy 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Christopher Baines 2023-03-04gnu: Remove and deprecate tidy for tidy-html...Morgan Smith 2023-02-19gnu: perl-cgi: Update to 4.55...Vasile Dumitrascu via Guix-patches via 2023-02-19gnu: Use HTTPS package home pages wherever possible....Tobias Geerinckx-Rice 2023-02-21gnu: guix-data-service: Update to 0.0.1-39.8c2f97e....Christopher Baines 2023-02-17gnu: httrack: Update to 3.49.4....Nicolas Goaziou