aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2012, 2013, 2016, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages attr)
  #:use-module (guix licenses)
  #:use-module (gnu packages perl)
  #:use-module (gnu packages gettext)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils))

(define-public attr
  (package
    (name "attr")
    (version "2.5.1")
    (source (origin
              (method url-fetch)
              (uri (string-append "mirror://savannah/attr/attr-"
                                  version ".tar.gz"))
              (sha256
               (base32
                "1y6sibbkrcjygv8naadnsg6xmsqwfh6cwrqk01l0v2i5kfacdqds"))))
    (build-system gnu-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         ,@(if (target-hurd?)
               `((add-before 'configure 'skip-linux-syscalls
                   (lambda _
                     ;; Starting from 2.5.1, libattr includes Linux-specific
                     ;; calls to syscall(2).  Comment them out for GNU/Hurd
                     ;; and instead use the glibc-provided wrappers.
                     (substitute* "Makefile.in"
                       (("libattr/syscalls\\.c") "")
                       (("\tlibattr/la-syscalls\\.lo") "")
                       (("-Wl,[[:graph:]]+/libattr\\.lds") "")))))
               '())
         (replace 'check
           (lambda* (#:key target #:allow-other-keys)
             ;; Use the right shell.
             (substitute* "test/run"
               (("/bin/sh")
                (which "sh")))

             ;; When building natively, run the tests.
             ;;
             ;; Note that we use system* and unconditionally return #t here
             ;; to ignore the test result, because the tests will fail when
             ;; the build is performed on a file system without support for
             ;; extended attributes, and we wish to allow Guix to be built
             ;; on such systems.
             (unless target
               (system* "make" "tests" "-C" "test")))))))
    (inputs
     ;; Perl is needed to run tests; remove it from cross builds.
     (if (%current-target-system)
         '()
         `(("perl" ,perl))))
    (native-inputs
     `(("gettext" ,gettext-minimal)))

    (home-page "https://savannah.nongnu.org/projects/attr/")
    (synopsis "Library and tools for manipulating extended attributes")
    (description
     "Portable library and tools for manipulating extended attributes.")
    (license lgpl2.1+)))
js/commit/lib/transform.js?h=templatifyjs&id=e5f80afc53e7df3b0b57931a03dc3481ddd9c30e'>support destructured literals (#4278)Alex Lam S.L 2020-11-08support computed property name in object literal (#4268)Alex Lam S.L 2020-10-05retrofit `try-catch-finally` as block-scoped (#4178)...Alex Lam S.L 2020-05-05update links to repository after rename (#3847)Alex Lam S.L 2020-02-06export missing API for AST manipulation (#3707)Alex Lam S.L 2018-06-06general clean-ups (#3175)Alex Lam S.L 2018-04-02fix tree traversal on `AST_Do` (#3047)...Alex Lam S.L 2017-12-19Transform can be simplified when clone is not done. (#2621)Ondřej Španěl 2017-07-03clean up `TreeWalker.pop()` (#2195)...Alex Lam S.L 2017-04-12convert `AST_Seq` from binary tree to array (#1460)...Alex Lam S.L 2016-01-27Collapse single use var definitions...kzc 2015-11-11Rework has_directive...Mihai Bazon 2013-07-14Apply transformer to AST_VarDef's name...Mihai Bazon 2013-05-14Compress code passed to `new Function` if it's a constant....Mihai Bazon 2012-11-18fix #51Mihai Bazon 2012-10-12minorMihai Bazon 2012-10-09added $propdoc to AST nodes and some cleanups...Mihai Bazon 2012-10-09minor AST cleanup (AST_BlockStatement may inherit from AST_Block)Mihai Bazon 2012-10-03more cleanup (dropped AST_SwitchBlock)Mihai Bazon 2012-10-02"use strict";Mihai Bazon 2012-09-26compressor successfully moved to TreeTransformerMihai Bazon 2012-09-26checkpoint (refactoring, WIP)Mihai Bazon 2012-09-23properly drop mutually-referring declarations that are not otherwise...Mihai Bazon 2012-09-22tree transformer api (WIP)Mihai Bazon