aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2022 B. Wilson <elaexuotee@wilsonb.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages apple)
  #:use-module (gnu packages bison)
  #:use-module (guix build-system gnu)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module ((guix licenses) #:prefix license:))

(define-public apple-bash
  (package
    (name "apple-bash")
    (version "125")
    (source
      (origin
        (method git-fetch)
        (uri (git-reference
               (url "https://github.com/apple-oss-distributions/bash.git")
               (commit (string-append "bash-" version))))
        (sha256
          (base32 "1d4s1z57yiyhgb6i22kb9al31j1fv9a4rp1bb747ny6grdvc4919"))
        (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (native-inputs (list bison))
    (arguments
      '(#:phases
        (modify-phases %standard-phases
          (add-before 'configure 'pre-configure
            (lambda _
              ;; An XCode project wraps the actual bash source.
              (chdir "bash-3.2")
              ;; The xlocale.h header was removed in glibc 2.26.
              (substitute* "lib/glob/smatch.c"
                (("xlocale.h") "locale.h"))
              ;; EBADEXEC is XNU-specific.
              (substitute* "execute_cmd.c"
                (("EBADEXEC") "ENOEXEC")))))))
    (home-page "https://github.com/apple-oss-distributions/bash/")
    (synopsis "Bash used on Apple macOS systems")
    (description
     "This is the version of Bash, forked from GNU Bash 3.2, released on Apple
macOS systems.")
    (license license:gpl2+)))
tion)[native-inputs]: likewise. * gnu/packages/zile.scm (zile)[native-inputs]: likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Maxime Devos 2021-03-11gnu: jetring: Update to 0.30....* gnu/packages/gnupg.scm (jetring): Update to 0.30. Tobias Geerinckx-Rice 2021-02-11Merge branch 'master' into core-updatesDanny Milosavljevic 2021-02-08gnu: gnupg: Update to 2.2.27....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.27. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Vincent Legoll 2021-02-03Merge branch 'master' into core-updatesChristopher Baines 2021-02-01gnu: pinentry-rofi: Update to 2.0.3....* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.3. [arguments]: Add make installcheck phase to verify the installed artifact. [native-inputs]: Add autoconf-archive. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Fredrik Salomonsson 2021-01-28gnu: pinentry-rofi: Update to 2.0.2....* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.2. [arguments]: Simplify the package definition. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Fredrik Salomonsson 2021-01-27gnu: guile-gcrypt: Refer to the right libgcrypt when cross-compiling....Fixes a regression introduced in 5e163ba00969e7ba05897840a1199b967252b4ae where (gcrypt package-config) would end up referring to the native libgcrypt.so instead of the target one. * gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: Reintroduce 'add-libgrypt-config' phase. [native-inputs]: Remove LIBGCRYPT. Ludovic Courtès 2021-01-27gnu: pinentry-efl: Tweak description....* gnu/packages/gnupg.scm (pinentry-efl)[description]: Use @acronym. Tobias Geerinckx-Rice 2021-01-27gnu: pinentry-tty: Update to 1.1.1....* gnu/packages/gnupg.scm (pinentry-tty): Update to 1.1.1. (pinentry-efl)[source]: Remove patch. * gnu/packages/patches/pinentry-efl.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. Tobias Geerinckx-Rice 2021-01-26gnu: guile-gcrypt: Build sequentially and reproducibly....* gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: New field. Ludovic Courtès 2021-01-26gnu: guile-gcrypt: Add libgcrypt to 'native-inputs'....* gnu/packages/gnupg.scm (guile-gcrypt)[arguments]: Remove. [native-inputs]: Add LIBGCRYPT. Ludovic Courtès 2021-01-13Merge branch 'staging' into 'core-updates'....Conflicts: gnu/local.mk gnu/packages/cmake.scm gnu/packages/curl.scm gnu/packages/gl.scm gnu/packages/glib.scm gnu/packages/guile.scm gnu/packages/node.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/python-xyz.scm gnu/packages/python.scm gnu/packages/tls.scm gnu/packages/vpn.scm gnu/packages/xorg.scm Maxim Cournoyer 2021-01-13gnu: Add pinentry-rofi....* gnu/packages/gnupg.scm (pinentry-rofi): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fredrik Salomonsson 2021-01-12gnu: gpgme: Update to 1.15.1....* gnu/packages/gnupg.scm (gpgme): Update to 1.15.1. Tobias Geerinckx-Rice 2020-11-30gnu: signing-party: Update to 2.11....* gnu/packages/gnupg.scm (signing-party): Update to 2.11. Tobias Geerinckx-Rice 2020-11-29Merge remote-tracking branch 'origin/master' into core-updatesChristopher Baines 2020-11-26Merge branch 'master' into stagingMarius Bakke 2020-11-25gnu: gnupg: Update to 2.2.25....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.25. Marius Bakke 2020-11-25gnu: libksba: Update to 1.5.0....* gnu/packages/gnupg.scm (libksba): Update to 1.5.0. Marius Bakke 2020-11-25gnu: Remove gnupg-2....This package was marked as superseded by gnupg in December 2017. * gnu/packages/gnupg.scm (gnupg-2): Remove variable. Efraim Flashner 2020-11-19Merge branch 'master' into stagingMarius Bakke 2020-11-18gnu: libgcrypt: Update to 1.8.7....* gnu/packages/gnupg.scm (libgcrypt): Update to 1.8.7. Miguel Ángel Arruga Vivas 2020-11-18gnu: libgpg-error: Update to 1.39....* gnu/packages/gnupg.scm (libgpg-error): Update to 1.39. Miguel Ángel Arruga Vivas 2020-11-18gnu: gpgme: Update to 1.15.0....* gnu/packages/gnupg.scm (gpgme): Update to 1.15.0. Miguel Ángel Arruga Vivas 2020-11-17gnu: gnupg: Update to 2.2.24....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.24. Miguel Ángel Arruga Vivas 2020-11-17gnu: libksba: Update to 1.4.0....* gnu/packages/gnupg.scm (libksba): Update to 1.4.0. Miguel Ángel Arruga Vivas 2020-11-17gnu: libassuan: Update to 2.5.4....* gnu/packages/gnupg.scm (libassuan): Update to 2.5.4. Miguel Ángel Arruga Vivas 2020-11-08gnu: libgpg-error: Fix cross-compiling to mips64el-linux....* gnu/packages/gnupg.scm (libgpg-error)[arguments]: When cross compiling create a symlink for mips64el. Efraim Flashner 2020-09-23gnu: libgcrypt: Update to 1.8.6....* gnu/packages/gnupg.scm (libgcrypt): Update to 1.8.6. Efraim Flashner 2020-09-08gnu: pinentry: Enable curses fallback....* gnu/packages/gnupg.scm (pinentry-gtk2, pinentry-gnome3, pinentry-qt, pinentry-efl)[arguments]: Add configure-flag for fallback curses mode. Efraim Flashner 2020-09-03gnu: gnupg: Update to 2.2.23 [security fixes]....No CVE assigned yet. See <https://dev.gnupg.org/T5050>. * gnu/packages/gnupg.scm (gnupg): Update to 2.2.23. Tobias Geerinckx-Rice 2020-08-28gnu: gnupg: Update to 2.2.22....* gnu/packages/gnupg.scm (gnupg): Update to 2.2.22. Efraim Flashner 2020-08-28gnu: gpgme: Update to 1.14.0....* gnu/packages/gnupg.scm (gpgme): Update to 1.14.0. [arguments]: Remove field, which included only a 'disable-failing-test' phase that is no longer needed. Mark H Weaver