aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages anthy)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public anthy
  (package
    (name "anthy")
    (version "9100h")
    (source
     (origin
       (method url-fetch)
       ;; The URI does not appear to be easily guessable.  For
       ;; example, you cannot download version "9100g" simply
       ;; by replacing "9100h" in the URI.
       (uri (list (string-append "https://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
                                 "distfiles/31/anthy-9100h.tar.gz")
                  "https://osdn.dl.osdn.net/anthy/37536/anthy-9100h.tar.gz"))
       (sha256
        (base32 "0ism4zibcsa5nl77wwi12vdsfjys3waxcphn1p5s7d0qy1sz0mnj"))))
    (build-system gnu-build-system)
    ;; Anthy also contains elisp modules for using anthy within Emacs.
    ;; However, these modules are incompatible with the latest version
    ;; of Emacs.  This is because they rely on the presence of
    ;; last-command-char, which was removed in Emacs 24.3.  So, we
    ;; don't try to install them here at this time.
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'check
           (lambda _
             (with-directory-excursion "test"
               (invoke "./anthy" "--all")))))))
    (home-page "https://anthy.osdn.jp/")
    (synopsis "Japanese input method")
    (description "Anthy is a Japanese input method for converting
hiragana text to mixed kana and kanji.  It is written in the C
programming language.  Anthy stores personal customizations (words it
has learned from the user's input, words the user has explicitly
added, etc.) in the @file{~/.anthy/} directory.  This package contains the
anthy C libraries, the cannadic and alt-cannadic kana dictionaries, as
well as command-line tools for using anthy and managing
dictionaries.")
    ;; Most of anthy is lgpl2.1+.  However, some files (e.g., from
    ;; alt-cannadic) use gpl2.  See the file "COPYING" in the anthy
    ;; source for details.
    (license (list lgpl2.1+ gpl2))))
nd adjust local code snippets. (Guix Environment)[cross-compilation]: Change mips64el-linux-gnu to aarch64-linux-gnu. (GNU Build System)(package-cross-derivation]: Same. (G-Expressions)[cross compilation]: Same. (Additional Build Options)[cross-compilation, build logs]: Same. (qemu-binfmt-service-type): Remove mips64el. * doc/contributing.texi (Submitting Patches): Same. * m4/guix.m4: (GUIX_ASSERT_SUPPORTED_SYSTEM): Remove mips64el-linux. Efraim Flashner 2020-05-25doc: Fix typos....* doc/guix.texi: Fix typos. * doc/contributing.texi: Fix typos. Signed-off-by: Julien Lepiller <julien@lepiller.eu> zimoun 2020-05-22maint: Add "make check-channel-news"....* build-aux/check-channel-news.scm: New file. * Makefile.am (EXTRA_DIST): Add it. (check-channel-news): New phony rule. * doc/contributing.texi (Commit Access): Mention "make check-channel-news". Ludovic Courtès 2020-05-12doc: Specify the branch name in the title of a patch....* doc/contributing.texi (Submitting Patches): Add branch name in the title of a patch if different than master. Brice Waegeneire 2020-05-04doc: Recommend against SHA1 OpenPGP signatures....* doc/contributing.texi (Commit Access): Recommend against SHA1 signatures. Ludovic Courtès 2020-05-04doc: Document committer authorization....* doc/contributing.texi (Commit Access): Add instructions for authorizing committers. Ludovic Courtès 2020-03-13doc: Update guidance about Python 2 package variants....* doc/contributing.texi (Python Modules): Don't recommend adding Python-2 package variants by default. Leo Famulari 2020-03-10doc: Use HTTPS for external links....* doc/contributing.texi (14.1 Building from Git, 14.3 The Perfect Setup, 14.4.1 Software Freedom, 14.4.4 Synopses and Descriptions, 14.5.4 Formatting Code): Use HTTPS for @uref{}s and @url{}s that support it. * doc/fdl-1.3.texi (Appendix A GNU Free Documentation License): Use HTTPS for @uref{}s and @url{}s that support it. * doc/guix.texi (6.3 Build Systems, 8.8.4 Networking Services, 8.8.8 Sound Services, 8.8.16 Web Services, 8.11 Name Service Switch, 12.2 Preparing to Use the Bootstrap Binaries); Use HTTPS for @uref{}s and @url{}s that support it. Signed-off-by: Marius Bakke <mbakke@fastmail.com> Vitaliy Shatrov 2020-03-09doc: Use an https link for Contributor Covenant....* doc/contributing.texi: Switch to https for the link to contributor-covenant.org Reported-By: guix-vits on IRC Jakub Kądziołka 2020-02-22etc: Add copyright....* etc/copyright.el: New file. * doc/contributing.texi (The Perfect Setup): Document this. Oleg Pykhalov 2020-02-18doc: Document packaging guidelines for Rust crates....* doc/contributing.texi (Rust Crates): New section. Efraim Flashner 2020-01-19Use HTTPS for www.emacswiki.org....* doc/contributing.texi (The Perfect Setup): Use HTTPS for ParEdit wiki page. * gnu/packages/emacs-xyz.scm (emacs-wget, emacs-iedit)[home-page]: Use HTTPS. (emacs-transpose-frame)[source]: Likewise. Tobias Geerinckx-Rice 2020-01-09doc: Add a cooptation policy for commit access....* doc/contributing.texi (Commit Access): Draft a cooptation policy. Ludovic Courtès 2020-01-09doc: Encourage patch review....* doc/contributing.texi (Commit Access): Add note about patch review. Ludovic Courtès 2020-01-09doc: Move "Commit Access" section from 'HACKING' to the manual....* HACKING (Commit Access): Remove. (Contributing): Update URL of the manual. * doc/contributing.texi (Commit Access): New section. (Submitting Patches): Add cross reference. Ludovic Courtès 2020-01-09doc: Add "Tracking Bugs and Patches" section....* doc/contributing.texi (Tracking Bugs and Patches): New section. (Submitting Patches): Refer to it. * doc/guix.texi: Update copyright line. * HACKING (Using emacs-debbugs): Remove. Ludovic Courtès 2019-12-27doc: Mention "make authenticate"....* doc/contributing.texi (Building from Git): Add instructions to run 'git verify-commit' and 'make authenticate'. Ludovic Courtès 2019-12-13doc: Link to "Building from Git" instead of quoting command to build Guix....* doc/contributing.texi (Submitting Patches): Remove example. Add link to "Building from Git" section. Pierre Neidhardt 2019-12-08doc: Mention how to simulate a `guix pull' before submitting patches....* doc/contributing.texi (Submitting Patches): Mention the dummy guix pull command in the check list. Pierre Neidhardt 2019-12-08doc: Mention how to rebuild guix before submitting patches....* doc/contributing.texi (Submitting Patches): Mention rebuild command in the check list. Pierre Neidhardt 2019-11-09doc: Mention value /var to localstatedir option....* README (Installing Guix from Guix): Mention value /var to localstatedir option. * doc/contributing.texi (Building from Git): Likewise. * doc/guix.texi (Requirements): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org> zimoun 2019-09-07doc: Use @lisp instead of @example for Scheme snippets....This is a followup to f8c143a7131d6f40f387f4cd2ad1fa78b5e2f429, which allows syntax highlighting of @lisp snippets in the HTML output. * doc/guix.texi, doc/contributing.texi: Use @lisp instead of @example for all the Scheme snippets. Ludovic Courtès 2019-07-17doc: Reorder and clarify contributing instructions....* doc/contributing.texi (Building from Git, Running Guix Before It Is Installed): Make instructions using Guix come first and clarify which code is an instruction and which is merely an example. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Florian Pelz 2019-07-15doc: note how to install git send-email...* doc/contributing.texi (git send-email): Add install instructions. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Arne Babenhauserheide 2019-06-29doc: Remove references to hydra.gnu.org....* doc/contributing.texi (Packaging Guidelines, Submitting Patches): Replace hydra URL with @value{SUBSTITUTE-SERVER}. * doc/guix.texi (Official Substitute Server): Remove ‘hydra’ @cindex. (Substitute Server Authorization): Remove note about hydra.gnu.org.pub. Tobias Geerinckx-Rice 2019-05-20doc: use pure environment when building from git...* doc/contributing.texi (Building from Git): Add --pure to "guix environment" invocations Signed-off-by: Ludovic Courtès <ludo@gnu.org> Giovanni Biscuolo