aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages anthy)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public anthy
  (package
    (name "anthy")
    (version "9100h")
    (source
     (origin
       (method url-fetch)
       ;; The URI does not appear to be easily guessable.  For
       ;; example, you cannot download version "9100g" simply
       ;; by replacing "9100h" in the URI.
       (uri (list (string-append "https://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
                                 "distfiles/31/anthy-9100h.tar.gz")
                  "https://osdn.dl.osdn.net/anthy/37536/anthy-9100h.tar.gz"))
       (sha256
        (base32 "0ism4zibcsa5nl77wwi12vdsfjys3waxcphn1p5s7d0qy1sz0mnj"))))
    (build-system gnu-build-system)
    ;; Anthy also contains elisp modules for using anthy within Emacs.
    ;; However, these modules are incompatible with the latest version
    ;; of Emacs.  This is because they rely on the presence of
    ;; last-command-char, which was removed in Emacs 24.3.  So, we
    ;; don't try to install them here at this time.
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'check
           (lambda _
             (with-directory-excursion "test"
               (invoke "./anthy" "--all")))))))
    (home-page "https://anthy.osdn.jp/")
    (synopsis "Japanese input method")
    (description "Anthy is a Japanese input method for converting
hiragana text to mixed kana and kanji.  It is written in the C
programming language.  Anthy stores personal customizations (words it
has learned from the user's input, words the user has explicitly
added, etc.) in the @file{~/.anthy/} directory.  This package contains the
anthy C libraries, the cannadic and alt-cannadic kana dictionaries, as
well as command-line tools for using anthy and managing
dictionaries.")
    ;; Most of anthy is lgpl2.1+.  However, some files (e.g., from
    ;; alt-cannadic) use gpl2.  See the file "COPYING" in the anthy
    ;; source for details.
    (license (list lgpl2.1+ gpl2))))
afa67d911690c2fa'>gnu: Add perl-digest-crc....Paul Garlick 2020-04-07gnu: Add perl-scalar-string....Paul Garlick 2020-04-03gnu: Add perl-data-entropy....Paul Garlick 2020-04-03gnu: Add perl-crypt-rijndael....Paul Garlick 2020-04-03gnu: Add perl-data-float....Paul Garlick 2020-04-01gnu: Add perl-crypt-eksblowfish....Paul Garlick 2020-03-31gnu: Add perl-class-mix....Paul Garlick 2020-03-31gnu: Add perl-params-classify....Paul Garlick 2020-03-31gnu: Add perl-devel-callchecker....Paul Garlick 2020-03-31gnu: Add perl-dynaloader-functions....Paul Garlick 2020-03-24gnu: perl-mail-sendmail: Add line above definition....Paul Garlick 2020-03-24gnu: Add perl-mail-sendmail....Paul Garlick 2020-03-23gnu: Add circos....Roel Janssen 2020-03-14Merge branch 'master' into stagingMarius Bakke 2020-03-13gnu: perl-test2-suite: Correct name....Tobias Geerinckx-Rice 2020-03-09Merge branch 'master' into stagingMarius Bakke 2020-03-09gnu: perl-timedate: Update to 2.32....Tobias Geerinckx-Rice 2020-03-09gnu: perl-xs-object-magic: Update to 0.05....Tobias Geerinckx-Rice 2020-03-09gnu: perl-datetime-format-strptime: Update to 1.77....Tobias Geerinckx-Rice 2020-03-09gnu: perl-datetime: Update to 1.52....Tobias Geerinckx-Rice 2020-03-09gnu: Add perl-math-vecstat....Roel Janssen 2020-03-08gnu: Add perl-config-inifiles....Roel Janssen 2020-03-08gnu: Add perl-attribute-util....Roel Janssen 2020-03-04Merge branch 'master' into stagingMarius Bakke 2020-03-04gnu: Add perl-pdf-api2....Roel Janssen 2020-02-14gnu: perl-ipc-system-simple: Update to 1.26....Marius Bakke 2020-02-14gnu: perl-term-readkey: Update to 2.38....Marius Bakke 2020-02-10gnu: Add perl-config-grammar....Vincent Legoll 2020-01-22gnu: perl-term-readline-gnu: Fix library initialization....Eric Bavier 2020-01-22gnu: perl-type-tiny: Update to 1.008003....Marius Bakke 2020-01-22gnu: perl-time-local: Update to 1.28....Marius Bakke 2020-01-22gnu: perl-timedate: Update to 2.31....Marius Bakke 2020-01-22gnu: perl-cpanel-json-xs: Update to 4.18....Marius Bakke 2020-01-17gnu: Add perl-term-readline-gnu....Eric Bavier 2020-01-06gnu: perl-ole-storage-lite: Update to 0.20....Efraim Flashner 2019-12-30gnu: Add perl-net-bgp....Stephen Scheck