aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages anthy)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public anthy
  (package
    (name "anthy")
    (version "9100h")
    (source
     (origin
       (method url-fetch)
       ;; The URI does not appear to be easily guessable.  For
       ;; example, you cannot download version "9100g" simply
       ;; by replacing "9100h" in the URI.
       (uri (list (string-append "https://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
                                 "distfiles/31/anthy-9100h.tar.gz")
                  "https://osdn.dl.osdn.net/anthy/37536/anthy-9100h.tar.gz"))
       (sha256
        (base32 "0ism4zibcsa5nl77wwi12vdsfjys3waxcphn1p5s7d0qy1sz0mnj"))))
    (build-system gnu-build-system)
    ;; Anthy also contains elisp modules for using anthy within Emacs.
    ;; However, these modules are incompatible with the latest version
    ;; of Emacs.  This is because they rely on the presence of
    ;; last-command-char, which was removed in Emacs 24.3.  So, we
    ;; don't try to install them here at this time.
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (replace 'check
           (lambda _
             (with-directory-excursion "test"
               (invoke "./anthy" "--all")))))))
    (home-page "https://anthy.osdn.jp/")
    (synopsis "Japanese input method")
    (description "Anthy is a Japanese input method for converting
hiragana text to mixed kana and kanji.  It is written in the C
programming language.  Anthy stores personal customizations (words it
has learned from the user's input, words the user has explicitly
added, etc.) in the @file{~/.anthy/} directory.  This package contains the
anthy C libraries, the cannadic and alt-cannadic kana dictionaries, as
well as command-line tools for using anthy and managing
dictionaries.")
    ;; Most of anthy is lgpl2.1+.  However, some files (e.g., from
    ;; alt-cannadic) use gpl2.  See the file "COPYING" in the anthy
    ;; source for details.
    (license (list lgpl2.1+ gpl2))))
ages/libreoffice.scm (libwps): Update to 0.4.12. Tobias Geerinckx-Rice 2020-08-30gnu: libreoffice: Update to 6.4.6.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.6.2. Fix indentation. Nicolas Goaziou 2020-07-13gnu: libreoffice: Update to 6.4.5.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.5.2. [source]: Remove patch. * gnu/packages/patches/libreoffice-poppler-compat.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Efraim Flashner 2020-06-10gnu: libnumbertext: Update to 1.0.6....* gnu/packages/libreoffice.scm (libnumbertext): Update to 1.0.6. Tobias Geerinckx-Rice 2020-06-03gnu: Add Polish hunspell dictionary....* gnu/packages/libreoffice.scm (hunspell-dict-pl): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Marcin Karpezo 2020-06-02gnu: libreoffice: Update to 4.4.2.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 4.4.2.2. [arguments]: Remove unrecognized configure-flag. Efraim Flashner 2020-04-03gnu: libreoffice: Fix build with Poppler 0.86....* gnu/packages/patches/libreoffice-poppler-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/libreoffice.scm (libreoffice)[source](patches): New field. Marius Bakke 2020-03-30Merge branch 'master' into core-updates... Conflicts: gnu/packages/admin.scm gnu/packages/commencement.scm gnu/packages/guile.scm gnu/packages/linux.scm gnu/packages/package-management.scm gnu/packages/pulseaudio.scm gnu/packages/web.scm Marius Bakke 2020-03-29gnu: libreoffice: Update to 6.4.2.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.2.2. Marius Bakke 2020-03-21Merge branch 'master' into core-updatesMarius Bakke 2020-03-21gnu: Use ‘license:’ prefix in (gnu packages libreoffice)....* gnu/packages/libreoffice.scm: Import (guix licenses) with a #:prefix and adjust all callers. Tobias Geerinckx-Rice 2020-03-18Merge branch 'master' into core-updatesMarius Bakke 2020-03-14gnu: LibreOffice: Update to 6.4.1.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.1.2. Leo Famulari 2020-03-04Merge branch 'master' into core-updatesMarius Bakke