aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages ada)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix build-system gnu)
  #:use-module (guix packages)
  #:use-module (guix git-download)
  #:use-module (gnu packages)
  #:use-module (gnu packages base)
  #:use-module (ice-9 match))

(define-public ada/ed
  (package
    (name "ada-ed")
    (version "1.11.2")
    (source
     (origin
       (method git-fetch)
       (uri (git-reference
             ;; The HOME-PAGE sources, mirrored by one of the original authors.
             (url "https://github.com/daveshields/AdaEd")
             (commit "57daecfb7ccadfd9aaf13b4d54f51065affbe599")))
       (sha256
        (base32 "1k97a8nqsvbsadizrmhhypcx758sxqkai8wq3ckk853qxvzaasd8"))
       (file-name (git-file-name name version))))
    (build-system gnu-build-system)
    (supported-systems (list "i686-linux" "x86_64-linux"
                             "armhf-linux" "aarch64-linux"
                             "powerpc-linux"))
    (outputs (list "out" "debug"))
    (arguments
     `(#:system
       ,@(match (%current-system)
           ;; This package predates 64-bit PCs: a ‘64-bit’ adaexec segfaults.
           ;; Force a 32-bit build targeting a similar architecture.
           ("aarch64-linux"
            `("armhf-linux"))
           ("x86_64-linux"
            `("i686-linux"))
           (_
            (list (%current-system))))
       #:make-flags
       (let ((out (assoc-ref %outputs "out")))
         (list (string-append
                "CFLAGS=-g"             ; compile with :debug symbols
                " -DOP_SYS='\"GNU\"'"   ; sic; quoting gets mangled somewhere
                " -DSYSTEM_V"           ; closest to modern GNU
                " -DWORDSIZE32"
                " -DALIGN4")            ; suffices on both x86 and ARM
               "LFLAGS="                ; don't link against -lg
               (string-append "BINDIR=" out "/bin")
               (string-append "LIBDIR=" out "/lib")
               (string-append "MANDIR=" out "/share/man")))
       #:modules ((guix build gnu-build-system)
                  (guix build utils)
                  (srfi srfi-26))
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'patch-sources
           (lambda _
             ;; Rename the custom (and incompatible) getline() implementation.
             (substitute* "adalex.c"
               (("getline") "adaed_getline"))
             ;; Work around ‘error: initializer element is not constant’ by not
             ;; initialising MSGFILE.
             (substitute* "vars.ch"
               (("INIT\\(stdout\\)") ""))
             #t))
         (delete 'configure)            ; no configure script
         (add-before 'build 'find-build-scripts
           (lambda _
             (setenv "PATH" (string-append ".:" (getenv "PATH")))
             #t))
         (add-after 'build 'build-predef
           (lambda* (#:key make-flags #:allow-other-keys)
             ;; These aren't otherwise compiled until the ‘install’ phase.
             (apply invoke "make" "predef" make-flags)
             #t))
         (delete 'check)                ; no test suite; run our own below
         (add-before 'install 'create-output-directories
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (mkdir-p (string-append out "/share/man/manl"))
               #t)))
         (add-after 'install 'check
           ;; Run most of the included demos as our own ‘test suite’.
           (lambda* (#:key outputs tests? #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (when tests?
                 (setenv "ADAED" (string-append out "/lib"))
                 (setenv "PATH" (string-append out "/bin:" (getenv "PATH")))
                 (with-directory-excursion "demos" ; won't run outside of it
                   (for-each
                    delete-file
                    '("runc"   ; ‘invalid data. Please make it a positive no.’
                      "rund"   ; deadlocks by design
                      "rune"   ; ‘dining2.ada: No such file or directory’
                      "rung")) ; ‘mathlib cannot be used as a library’ (!)
                   (for-each (lambda (script)
                               (format #t "\n=== Invoking ~a ===\n" script)
                               (invoke script))
                             (find-files "." "^run")))))))
         (add-after 'install 'clean-up-output
           (lambda* (#:key outputs #:allow-other-keys)
             (let ((out (assoc-ref outputs "out")))
               (with-directory-excursion out
                 ;; These needn't be executable.
                 (for-each (cut chmod <> #o644)
                           (append (find-files "lib" "\\....$")
                                   (find-files "share" ".")))
                 #t)))))))
    (native-inputs
     (list sed))
    (home-page (string-append "https://web.archive.org/web/20140902150609/"
                              "http://www2.informatik.uni-stuttgart.de/iste/ps/"
                              "ada-software/html/dos_ada.html"))
    (synopsis "Ada 83 interpreter")
    (description "Ada/Ed is a translator-interpreter for Ada 83.  It's intended
primarily as a teaching tool and lacks the capacity, performance, and robustness
of other contemporary or modern-day Ada compilers.

Ada/Ed was the first Ada compiler to pass the @acronym{ACVC, Ada Compiler
Validation Suite} version 1.7 but fails many newer tests and is not a validated
Ada system.  Being an interpreter, it does not implement most representation
clauses, and thus does not support systems programming close to the machine
level.")
    (license license:gpl2+)))
ble with ... (openssl-1.1.1g): ... this. Leo Famulari 2020-04-20gnu: tls: Remove datefudge and disable tests on the Hurd....* gnu/packages/tls.scm (gnutls)[arguments]: When compiling for the Hurd, disable tests. [native-inputs]: When compiling for the Hurd, do not include datefudge. Jan (janneke) Nieuwenhuizen 2020-04-11gnu: gnutls-3.6.13: Cross-build fix....* gnu/packages/patches/gnutls-cross.patch: New file. * gnu/packages/tls.scm (gnutls-3.6.13)[source]: Use it. [native-inputs]: If cross-compiling, add native guile-3.0. This actually cross compiles .go modules. Jan (janneke) Nieuwenhuizen 2020-04-11gnu: openssl: Support cross-compilation to the Hurd....* gnu/packages/tls.scm (openssl)[arguments]: Add `i586' => hurd-x86 platform setting. Jan (janneke) Nieuwenhuizen 2020-04-11Merge branch 'master' into core-updatesMarius Bakke 2020-04-11gnu: openconnect: Update to 8.08....* gnu/packages/vpn.scm (openconnect): Update to 8.08. [propagated-inputs]: Use gnutls-3.6.13. * gnu/packages/tls.scm (gnutls-3.6.13): Export it. Tobias Geerinckx-Rice 2020-04-08Merge branch 'master' into core-updates... Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm Marius Bakke 2020-04-06gnu: GnuTLS: Fix CVE-2020-11501....* gnu/packages/tls.scm (gnutls)[replacement]: New field. (gnutls-3.6.13): New variable. (gnutls/guile-2.0, gnutls/dane, gnutls-3.6.10, gnutls3.0-gnutls): Use PACKAGE/INHERIT. Leo Famulari 2020-03-31gnu: OpenSSL: Update to 1.1.1f....* gnu/packages/patches/openssl-1.1.1e-revert-detect-eof.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/tls.scm (openssl): Update to 1.1.1f. [source](patches): Remove obsolete patch. Marius Bakke 2020-03-29gnu: gnutls: Remove net-tools for the Hurd....* gnu/packages/tls.scm (gnutls)[inputs]: Remove net-tools for the Hurd. Jan Nieuwenhuizen 2020-03-26gnu: OpenSSL: Add upstream patch to preserve compatibility in EOF handling....This is a follow-up to ad8254c23a86c3ca4ca32bc68fc8d76954aa80fd, which unexpectedly caused a test failure in the Python test suite. * gnu/packages/patches/openssl-1.1.1e-revert-detect-eof.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/tls.scm (openssl)[source](patches): Add it. Marius Bakke 2020-03-26gnu: OpenSSL: Remove replacement package....* gnu/packages/tls.scm (openssl): Update to 1.1.1e. [replacement]: Remove. (openssl-1.1.1e): Remove variable. Marius Bakke 2020-03-19Merge branch 'master' into core-updatesMarius Bakke 2020-03-19gnu: OpenSSL: Update replacement to 1.1.1e [fixes CVE-2019-1551]....* gnu/packages/tls.scm (openssl-1.1.1d): Rename to ... (openssl-1.1.1e): ... this. Update to 1.1.1e. (openssl)[replacement]: Adjust accordingly. Marius Bakke 2020-03-17gnu: gnutls: Make 'guile3.0-gnutls' a deprecated alias....This is a followup to 67a3c8ed15f62a39f8684ee9c8dda024de9296a9. * gnu/packages/tls.scm (guile3.0-gnutls): Make a deprecated alias for GNUTLS. Ludovic Courtès 2020-03-17gnu: GnuTLS: Build with Guile 3....This is a follow-up to commit b6bee63bed4f013064c0d902e7c8b83ed7514ade. * gnu/packages/tls.scm (gnutls)[inputs]: Change from GUILE-2.2 to GUILE-3.0. (guile3.0-gnutls): Rename to ... (guile2.2-gnutls): ... this. Use GUILE-2.2. (guile3.0-gnutls): New variable. Marius Bakke 2020-03-14Merge branch 'master' into core-updatesMarius Bakke 2020-03-11gnu: gnutls@3.6.10: Add dependency on datefudge and util-linux....* gnu/packages/tls.scm (gnutls-3.6.10)[native-inputs]: New field. Marius Bakke 2020-03-10gnu: Certbot, python-acme: Update to 1.3.0....* gnu/packages/tls.scm (certbot, python-acme): Update to 1.3.0. Leo Famulari