aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages acl)
  #:use-module (guix licenses)
  #:use-module (gnu packages attr)
  #:use-module (gnu packages base)
  #:use-module (gnu packages check)
  #:use-module (gnu packages gettext)
  #:use-module (gnu packages perl)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (gnu packages)
  #:use-module (guix build-system gnu)
  #:use-module (guix build-system python)
  #:use-module (guix utils))

(define-public acl
  (package
    (name "acl")
    (version "2.3.1")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://savannah/acl/acl-"
                          version ".tar.gz"))
      (sha256
       (base32
        "1bqi7hj0xkpivwg7lx5cv3yvs9ks1i6azvpgbvfpzcq1i736233n"))))
    (build-system gnu-build-system)
    (arguments
     `(#:modules ((ice-9 ftw)
                  ,@%default-gnu-modules)
       #:configure-flags '("--disable-static")
       #:tests? ,(not (or (%current-target-system)
                          (target-hurd?)))
       #:phases
       (modify-phases %standard-phases
         ;; XXX After repacking the sources the timestamps are reset to the
         ;; epoch, which leads to a failure in gzipping the CHANGES file.
         (add-after 'unpack 'ensure-no-mtimes-pre-1980
           (lambda _
             (let ((early-1980 315619200)) ; 1980-01-02 UTC
               (ftw "." (lambda (file stat flag)
                          (unless (<= early-1980 (stat:mtime stat))
                            (utime file early-1980 early-1980))
                          #t)))))
         (add-after 'build 'patch-exec-bin-sh
           (lambda _
             (substitute* "test/run"
               (("/bin/sh") (which "sh")))))
         (add-before 'check 'patch-tests
           (lambda _
             ;; The coreutils do not have an ACL bit to remove from their
             ;; output, so the sed expression that removes the bit is disabled.
             (substitute* "test/sbits-restore.test"
                          (("\\| sed.*'") ""))
             ;; These tests require the existence of a user named "bin", but
             ;; this user does not exist within Guix's build environment.
             (substitute* "Makefile.in"
               ((".*test/misc\\.test.*") "")
               ((".*test/cp\\.test.*") "")
               ((".*test/setfacl-X\\.test.*") "")))))))
    (inputs (list attr))
    (native-inputs (list gettext-minimal perl))
    (home-page "https://savannah.nongnu.org/projects/acl")
    (synopsis
     "Library and tools for manipulating access control lists")
    (description
     "Library and tools for manipulating access control lists.")
    (license (list gpl2+ lgpl2.1+))))

(define-public python-pylibacl
  (package
    (name "python-pylibacl")
    (version "0.6.0")
    (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pylibacl" version))
        (sha256
          (base32
            "1zyrk2m20p5b6bdwxhrwib273i6i71zyr5hzssbxfqis5qra9848"))))
    (build-system python-build-system)
    (arguments
     `(#:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'disable-tests
           (lambda* (#:key outputs inputs #:allow-other-keys)
             ;; These tests operate on real files, but our tmpfs does not support
             ;; ACLs.
             (substitute* "tests/test_acls.py"
               (("( *)def test_applyto(_extended(_mixed)?)?" match indent)
                (string-append indent "@pytest.mark.skip(reason=\"guix\")\n"
                               match)))))
         (replace 'check
           (lambda* (#:key inputs outputs tests? #:allow-other-keys)
             (when tests?
               (add-installed-pythonpath inputs outputs)
               (invoke "pytest" "tests")))))))
    (inputs (list acl))
    (native-inputs (list python-pytest))
    (home-page "https://pylibacl.k1024.org/")
    (synopsis "POSIX.1e @acronym{ACLs, access control lists} for Python")
    (description
     "This Python extension module manipulates the POSIX.1e @acronym{ACLs,
Access Control Lists} available on many file systems.  These allow more
fine-grained access control than traditional user/group permissions.")
    (license lgpl2.1+)))
106ea5c9f783da0b982bbf18ae81ad8065d7b7'>gnu: ffmpeg-jami: Add a debug output....* gnu/packages/jami.scm (ffmpeg-jami) [outputs]: New field. [configure-flags]: Add "--disable-stripping". Maxim Cournoyer 2023-02-08gnu: ffmpeg-jami: Really honor custom configuration flags....Because the substitute-keyword-arguments pattern was (#:configure-flags '()) rather than (#:configure-flags _ '()), the replacement was not triggered. * gnu/packages/jami.scm (%ffmpeg-default-configure-flags): Comment that the fnnvcodec-related options are left out. (%ffmpeg-linux-x86-configure-flags): Delete variable. (ffmpeg-compose-configure-flags): Streamline and use gexps. (ffmpeg-jami) [arguments]: Fix configure-flags pattern, and adjust to use gexps. Add the "--disable-static" and "--enable-shared" flags to produce shared objects with the correct RUNPATH. Maxim Cournoyer 2023-02-07gnu: jami: Update to 20230206.0....* gnu/packages/jami.scm (jami): Update to 20230206.0. (%jami-version): Update version. (%jami-sources): Adjust URI. Streamline snippet. (jami-apply-custom-patches): Use a wildcard to match the top-level directory, which now includes the version. (%ffmpeg-default-configure-flags): Adjust URL in top comment. * gnu/packages/patches/jami-libjami-headers-search.patch: Adjust file names for new tarball layout. Maxim Cournoyer 2023-01-08Merge branch 'master' into stagingMarius Bakke 2023-01-03gnu: jami-qt: Remove deprecated alias....* gnu/packages/jami.scm (jami-qt): Delete variable. Maxim Cournoyer 2023-01-03gnu: jami-gnome: Remove deprecated alias....* gnu/packages/jami.scm (jami-gnome): Delete variable. Maxim Cournoyer 2023-01-03gnu: libring: Remove deprecated alias....* gnu/packages/jami.scm (libring): Delete variable. Maxim Cournoyer 2022-12-28Merge branch 'master' into stagingMarius Bakke 2022-12-27gnu: jami: Update to 20221220.0956.79e1207....* gnu/packages/jami.scm (%jami-version): Update to 20221220.0956.79e1207. (%jami-sources): Remove all but the 'jami-disable-integration-tests.patch' and 'jami-libjami-headers-search.patch' patches. * gnu/packages/patches/jami-fix-qml-imports.patch: Delete file. * gnu/packages/patches/jami-fix-unit-tests-build.patch: Likewise. * gnu/packages/patches/jami-no-webengine.patch: Likewise. * gnu/packages/patches/jami-sip-contacts.patch: Likewise. * gnu/packages/patches/jami-sip-unregister.patch: Likewise. * gnu/packages/patches/jami-sipaccount-segfault.patch: Likewise. * gnu/packages/patches/jami-xcb-link.patch: Likewise. * gnu/local.mk (dist_patch_DATA): De-register them. Maxim Cournoyer 2022-12-12Merge remote-tracking branch 'origin/master' into stagingMaxim Cournoyer 2022-12-04gnu: jami: Apply a patch to fix a crash when using SIP....* gnu/packages/patches/jami-sipaccount-segfault.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/jami.scm (%jami-sources): Apply it. Maxim Cournoyer 2022-12-02Merge branch 'master' into stagingMarius Bakke 2022-11-29gnu: jami: Apply a patch to fix receiving of text messages over SIP....* gnu/packages/patches/jami-sip-contacts.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/jami.scm (%jami-sources): Apply it. Maxim Cournoyer 2022-11-20gnu: libvpx: Update to 1.12.0....* gnu/packages/video.scm (libvpx): Update to 1.12.0. (libvpx-next): Remove variable. * gnu/packages/jami.scm (ffmpeg-jami)[inputs]: Remove. Marius Bakke 2022-11-20gnu: libx264: Update to 164-0.b093bbe....* gnu/packages/video.scm (libx264): Update to 164-0.b093bbe. (libx264-next): Remove variable. * gnu/packages/jami.scm (ffmpeg-jami)[inputs]: Don't use LIBX264-NEXT. Marius Bakke 2022-11-12gnu: jami: Enable unit tests....* gnu/packages/patches/jami-fix-qml-imports.patch: New file. * gnu/packages/patches/jami-fix-unit-tests-build.patch: Likewise. * gnu/packages/patches/jami-libjami-headers-search.patch: Likewise. * gnu/packages/patches/jami-sip-unregister.patch: Likewise. * gnu/packages/patches/jami-xcb-link.patch: Likewise. * gnu/local.mk: Register them. * gnu/packages/jami.scm (%jami-sources): Apply new patches. (jami) [tests?]: Delete argument to run tests. [configure-flags]: Remove TESTS? argument. Enable tests with -DENABLE_TESTS=ON. Remove -DLIBJAMI_INCLUDE_DIR. [phases] {check}: New phase override. [native-inputs]: Add settings-desktop-schemas. [inputs]: Add glib and libxcb. Maxim Cournoyer 2022-11-11gnu: jami: Update to 20221031.1308.130cc26....* gnu/packages/jami.scm (libjami, jami): Update to 20221031.1308.130cc26. (%jami-sources): Remove jami-fix-crash-on-block-contact patch. Add jami-disable-integration-tests and jami-no-webengine patches. (pjproject-jami): Update to 2.12-1.513a3f1. (ffmpeg-jami): Replace libvpx with libvpx-next. Replace libx264 with libx264-next. (libjami): Update comment with upstream issue URL. [tests?]: Remove argument, enabling test suite. [configure-flags]: Remove "--disable-static". [phases] {delete-static-libraries}: New phase. (jami) [tests?]: Update comment. [configure-flags]: Remove "-DLIBJAMI_XML_INTERFACES_DIR=" flag. [phases] {patch-source}: Delete phase. * gnu/packages/patches/jami-fix-crash-on-block-contact.patch: Delete patch. * gnu/packages/patches/jami-disable-integration-tests.patch: New file. * gnu/packages/patches/jami-no-webengine.patch: New file. * gnu/local.mk (dist_patch_DATA): Update accordingly. Maxim Cournoyer 2022-11-08gnu: pjproject-jami: Restore hash....The hash was inadvertently changed in commit 071d4bdc80cbf6b3a5c1232f0d704878431a864f. * gnu/packages/jami.scm (pjproject-jami) [source]: Revert hash. Reported-by: Jack Hill <jackhill@jackhill.us> Maxim Cournoyer 2022-11-06gnu: Add jami-docs....* gnu/packages/jami.scm (jami-docs): New variable. Maxim Cournoyer 2022-11-06gnu: ccache: Update to 4.7.2....* gnu/packages/ccache.scm (ccache): Update to 4.7.2. Move inputs fields after arguments field. [native-inputs]: Add ruby-asciidoctor to generate man page. Maxim Cournoyer