aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages acct)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public acct
  (package
    (name "acct")
    (version "6.6.4")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/acct/acct-"
                          version ".tar.gz"))
      (sha256
       (base32
        "0gv6m8giazshvgpvwbng98chpas09myyfw1zr2y7hqxib0mvy5ac"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/acct/")
    (synopsis "Standard login and process accounting utilities")
    (description
     "GNU acct provides a means for system administrators to determine
system usage patterns.  It provides information on, for example, connections,
programs executed, and system resources used.")
    (license gpl3+)))
.* gnu/packages/libreoffice.scm (unoconv): New public variable. Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net> Tobias Geerinckx-Rice 2020-02-21gnu: libreoffice: Fix ‘soffice’ in a pure environment....* gnu/packages/libreoffice.scm (libreoffice)[arguments]: Refer to grep and coreutils by absolute file name in the soffice launcher script. Tobias Geerinckx-Rice 2020-02-17gnu: librevenge: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (librevenge)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-02-17gnu: orcus: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (orcus)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-02-17gnu: liblangtag: Update to 0.6.3....* gnu/packages/libreoffice.scm (liblangtag): Update to 0.6.3. Tobias Geerinckx-Rice 2020-02-17gnu: liblangtag: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (liblangtag)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2020-02-13gnu: LibreOffice: Update to 6.4.0.3....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.4.0.3. [inputs]: Add qrcodegen-cpp. [source]: Remove obsolete patches and substitutions. * gnu/packages/patches/libreoffice-glm.patch, gnu/packages/patches/libreoffice-icu.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Leo Famulari 2020-02-13gnu: libetonyek: Update MDDS requirement....* gnu/packages/libreoffice.scm (libetonyek): Put '--with-mdds-1.5' in #:configure-flags. Leo Famulari 2020-02-13gnu: orcus: Update to 0.15.3....* gnu/packages/libreoffice.scm (orcus): Update to 0.15.3. Leo Famulari 2020-02-13gnu: ixion: Update to 0.15.0....* gnu/packages/libreoffice.scm (ixion): Update to 0.15.0. [inputs]: Add spdlog. Leo Famulari 2020-02-05gnu: libcdr: Update to 0.1.6....* gnu/packages/libreoffice.scm (libcdr): Update to 0.1.6. Marius Bakke 2020-01-15gnu: python-lxml: Move to (gnu packages xml)....* gnu/packages/python-xyz.scm (python-lxml): Move from here ... * gnu/packages/xml.scm (python-lxml): ... to here. * gnu/packages/django.scm, gnu/packages/drones.scm, gnu/packages/libreoffice.scm, gnu/packages/nutrition.scm, gnu/packages/openstack.scm, gnu/packages/pulseaudio.scm, gnu/packages/python-science.scm, gnu/packages/tryton.scm, gnu/packages/wireservice.scm: Adjust module imports. Marius Bakke 2019-12-16gnu: libreoffice: Update to 6.3.4.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.3.4.2. Efraim Flashner 2019-12-12gnu: libwpd: Update to 0.10.3....* gnu/packages/libreoffice.scm (libwpd): Update to 0.10.3. Tobias Geerinckx-Rice 2019-11-15Merge branch 'master' into stagingMarius Bakke 2019-11-13gnu: libreoffice: Use the "dev" output of MariaDB....This is a fixup for the merge (32d6818569) of e0efda9561 (gnu: libreoffice: Update to 6.2.8.2.) and 2b8491fbbe (gnu: mariadb: Split into out, lib and dev.) * gnu/packages/libreoffice.scm (libreoffice)[inputs]: Change MARIADB to MARIADB:DEV. Marius Bakke 2019-11-01gnu: libreoffice: Update to 6.3.3.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.3.3.2. [inputs]: Add gnupg, gobject-introspection. [arguments]: Remove deprecated '--enable-verbose' configure flag. Efraim Flashner 2019-10-29gnu: libreoffice: Update to 6.2.8.2....* gnu/packages/libreoffice.scm (libreoffice): Update to 6.2.8.2. [sources]: Remove libreoffice-boost.patch, libreoffice-orcus patch, libreoffice-mdds patch. [inputs]: Add fontforge, mariadb. [arguments]: Remove substitution checking for mdds and orcus versions. From configure-flags, remove outdated flags, add flag to build font file. * gnu/packages/patches/libreoffice-boost.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Efraim Flashner 2019-09-06Merge branch 'master' into core-updatesMark H Weaver 2019-09-05gnu: libvisio: Update to 0.1.7....* gnu/packages/libreoffice.scm (libvisio): Update to 0.1.7. Marius Bakke 2019-09-05gnu: libabw: Update to 0.1.3....* gnu/packages/libreoffice.scm (libabw): Update to 0.1.3. [arguments]: Remove. Marius Bakke 2019-08-22Merge branch 'master' into core-updatesMark H Weaver 2019-08-21gnu: libabw: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libabw)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-07-22Merge branch 'master' into core-updatesMarius Bakke 2019-07-21gnu: libreoffice: Fix xdg-open absolute paths....Fixes: <https://bugs.gnu.org/36728>. * gnu/packages/libreoffice.scm (libreoffice) [inputs]: Add xdg-utils. [arguments][#:phases][prepare-src]: Replace hard-coded absolute paths to xdg-open in the source with the path to xdg-open in the xdg-utils input. Chris Marusich 2019-05-01Merge branch 'master' into core-updatesMarius Bakke 2019-04-23gnu: libmwaw: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libmwaw)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-04-23gnu: libodfgen: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libodfgen)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-04-23gnu: libvisio: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libvisio)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-04-23gnu: libpagemaker: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libpagemaker)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-04-23gnu: libmwaw: Update to 0.3.15....* gnu/packages/libreoffice.scm (libmwaw): Update to 0.3.15. Tobias Geerinckx-Rice 2019-04-04gnu: Move nss & co. to nss.scm....* gnu/packages/gnuzilla.scm (nspr, nss): Move to... * gnu/packages/nss.scm: ... here. New file. * gnu/packages/chromium.scm, gnu/packages/disk.scm, gnu/packages/freedesktop.scm, gnu/packages/gnome.scm, gnu/packages/gnunet.scm, gnu/packages/java.scm, gnu/packages/libreoffice.scm, gnu/packages/linux.scm, gnu/packages/mate.scm, gnu/packages/openldap.scm, gnu/packages/package-management.scm, gnu/packages/password-utils.scm, gnu/packages/polkit.scm, gnu/packages/qt.scm, gnu/packages/sssd.scm, gnu/packages/storage.scm, gnu/packages/vpn.scm, gnu/packages/web.scm, gnu/packages/xml.scm: Adjust accordingly. * gnu/local.mk (GNU_SYSTEM_MODULES): Add nss.scm. Ludovic Courtès 2019-03-23Merge branch 'staging' into core-updatesMarius Bakke 2019-03-16gnu: libwpd: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libwpd)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-03-16gnu: libwpg: Update to 0.3.3....* gnu/packages/libreoffice.scm (libwpg): Update to 0.3.3. Tobias Geerinckx-Rice 2019-03-16gnu: libwpg: Don't use NAME in source URI....* gnu/packages/libreoffice.scm (libwpg)[source]: Hard-code NAME. Tobias Geerinckx-Rice 2019-03-16gnu: libqxp: Update to 0.0.2....* gnu/packages/libreoffice.scm (libqxp): Update to 0.0.2. Tobias Geerinckx-Rice 2019-03-16gnu: libnumbertext: Update to 1.0.5....* gnu/packages/libreoffice.scm (libnumbertext): Update to 1.0.5. [source]: Use a release tarball. [native-inputs]: Remove autoconf, automake, libtool, and pkg-config. Tobias Geerinckx-Rice