aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages acct)
  #:use-module (guix licenses)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system gnu))

(define-public acct
  (package
    (name "acct")
    (version "6.6.4")
    (source
     (origin
      (method url-fetch)
      (uri (string-append "mirror://gnu/acct/acct-"
                          version ".tar.gz"))
      (sha256
       (base32
        "0gv6m8giazshvgpvwbng98chpas09myyfw1zr2y7hqxib0mvy5ac"))))
    (build-system gnu-build-system)
    (home-page "https://www.gnu.org/software/acct/")
    (synopsis "Standard login and process accounting utilities")
    (description
     "GNU acct provides a means for system administrators to determine
system usage patterns.  It provides information on, for example, connections,
programs executed, and system resources used.")
    (license gpl3+)))
+0300'>2023-10-18gnu: rust: Update to 1.70.0....* gnu/packages/rust.scm (rust): Update to 1.70.0. [arguments]: Remove 'patch-cargo-env-shebang phase. Adjust custom phases 'disable-tests-requiring-git, disable-tests-requiring-mercurial, 'patch-command-uid-gid-test for changes in the source. Simplify custom phases 'disable-tests-broken-on-aarch64, 'patch-process-tests, 'patch-command-exec-tests, 'disable-interrupt-tests. Efraim Flashner 2023-10-18gnu: rust: Add make-ignore-test-list function....A little helper function to make creating a list to ignore tests easier. * gnu/packages/rust.scm (make-ignore-test-list): New function. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Fries 2023-10-18gnu: Add rust-1.70....* gnu/packages/rust.scm (rust-1.70): New variable. * gnu/packages/patches/rust-1.70-fix-rustix-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register file. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Fries 2023-10-18gnu: Add rust-1.69....* gnu/packages/rust.scm (rust-1.69): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il> Fries 2023-09-16gnu: rust-1.55: Remove i586-gnu from supported-systems....* gnu/packages/rust.scm (rust-1.55)[supported-systems]: Remove i586-gnu. Christopher Baines 2023-09-09gnu: rust-analyzer: Fix build of version 2022-01-10....* gnu/packages/rust-apps.scm (rust-analyzer): Update dependency rust-notify-5-pre.13. This fixes the build of `rust-analyzer@2022-01-10`, which required a pinned version of `rust-notify` (`rust-notify-5-pre.13`) to compile and rust >= 1.64. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Distopico 2023-08-14gnu: rust: Update to 1.68.2....* gnu/packages/rust.scm (rust): Update to 1.68.2. [arguments]: Adjust 'skip-shebang-tests phase to moved files. Add 'adjust-rpath-values phase to link to shared libraries. Efraim Flashner