aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2023 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages abiword)
  #:use-module ((guix licenses) #:prefix license:)
  #:use-module (guix packages)
  #:use-module (guix download)
  #:use-module (guix build-system glib-or-gtk)
  #:use-module (guix gexp)
  #:use-module (gnu packages)
  #:use-module (gnu packages autotools)
  #:use-module (gnu packages boost)
  #:use-module (gnu packages compression)
  #:use-module (gnu packages enchant)
  #:use-module (gnu packages fribidi)
  #:use-module (gnu packages fontutils)
  #:use-module (gnu packages glib)
  #:use-module (gnu packages gnome)
  #:use-module (gnu packages gtk)
  #:use-module (gnu packages image)
  #:use-module (gnu packages ots)
  #:use-module (gnu packages popt)
  #:use-module (gnu packages pkg-config)
  #:use-module (gnu packages python)
  #:use-module (gnu packages readline)
  #:use-module (gnu packages wv)
  #:use-module (gnu packages xml))

(define-public abiword
  (package
    (name "abiword")
    (version "3.0.5")
    (source
      (origin
        (method url-fetch)
        (uri
         ;; XXX: The main site <https://www.abisource.com/> is down.  Only a (partial)
         ;;      mirror is available at <http://www.nl.abisource.com/>.
          (string-append "http://www.nl.abisource.com/downloads/abiword/" version
                         "/source/abiword-" version ".tar.gz"))
        (sha256
         (base32 "1d1179pnslijpjhz1q155fsc828rrlqf7lsn2inqsl3hk5z28mqj"))
        (patches
         (search-patches "abiword-explictly-cast-bools.patch"))))

    (build-system glib-or-gtk-build-system)
    (arguments                   ;; NOTE: rsvg is disabled, since Abiword
     (list #:configure-flags        ;; supports it directly, and its BS is broken.
           #~(list                    ;; wmf was removed from Guix for security.
              "--enable-clipart"     ;; TODO: The following plugins have unresolved
              "--enable-templates"   ;; dependencies: aiksaurus, grammar, wpg, gda,
              (string-append         ;; wordperfect, psion, mathview.
               "--enable-plugins="
               "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
               "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
               "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
               "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
               "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
               "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
               "wikipedia " "wml " "xslfo")
              "--enable-introspection"
              (string-append "--with-gir-dir="
                             #$output
                             "/share/gir-1.0")
              (string-append "--with-typelib-dir="
                             #$output
                             "/lib/girepository-1.0"))
           ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
           ;;                  assertion 'GDK_IS_SCREEN (screen)' failed
           ;;                  GLib-GObject-CRITICAL **: g_object_get_qdata:
           ;;                  assertion 'G_IS_OBJECT (object)' failed
           ;; Manually starting the X server before the test phase did not help
           ;; the tests to pass.
           #:tests? #f
           #:make-flags
           #~(list "gtk_update_icon_cache=true")))
    (inputs
     (list boost
           enchant
           fontconfig
           fribidi
           glib
           goffice
           gtk+
           libchamplain
           libglade
           libgsf
           libjpeg-turbo
           libpng
           (librsvg-for-system)
           libxml2
           libxslt
           ots
           popt
           readline
           telepathy-glib
           wv
           zlib))
    (native-inputs
     (list gobject-introspection
           intltool
           `(,glib "bin")
           libtool
           pkg-config
           python-wrapper))
    (home-page "http://www.nl.abisource.com/")
    (synopsis "Word processing program")

    ;; HACKERS: The comment below is here so that it shows up early in the
    ;; .pot file.

    ;; TRANSLATORS: Dear translator, We would like to inform you that package
    ;; descriptions may occasionally include Texinfo markup.  Texinfo markup
    ;; looks like "@code{rm -rf}", "@emph{important}", etc.  When translating,
    ;; please leave markup as is.
    (description "AbiWord is a word processing program.  It is rapidly
becoming a state of the art word processor, with lots of features useful for
your daily work, personal needs, or for just some good old typing fun.")
    (license license:gpl2+)))
n>Guillaume Le Vaillant 2023-05-22gnu: homebank: Update to 5.6.3....* gnu/packages/finance.scm (homebank): Update to 5.6.3. Signed-off-by: Ludovic Courtès <ludo@gnu.org> fanquake 2023-05-21gnu: xmrig: Update to 6.19.2....* gnu/packages/finance.scm (xmrig): Update to 6.19.2. [description]: Fix typos. Ahmad Draidi 2023-05-20gnu: bitcoin-core-24.1: Rename to bitcoin-core....* gnu/packages/finance.scm (bitcoin-core): Remove variable. (bitcoin-core-24.1): Rename to bitcoin-core. Guillaume Le Vaillant 2023-05-19gnu: bitcoin-core: Update to 24.1....* gnu/packages/finance.scm (bitcoin-core): Update to 24.1. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Michael Ford 2023-05-19gnu: bitcoin-unlimited: Update to 2.0.0.0....* gnu/packages/finance.scm (bitcoin-unlimited): Update to 2.0.0.0. [arguments]: Update 'fix-tests' phase. Guillaume Le Vaillant 2023-05-14gnu: bitcoin-core: Update to 23.1....* gnu/packages/finance.scp (bitcoin-core): Update to 23.1. [inputs]: Add sqlite. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net> Michael Ford 2023-04-23gnu: python-ledgerblue: Disable tests....* gnu/packages/finance.scm (python-ledgerblue)[arguments]: Disable tests (there are none). John Kehayias 2023-04-22gnu: python-stdnum: Update to 1.18....* gnu/packages/finance.scm (python-stdnum): Update to 1.18. Andreas Enge 2023-04-19gnu: Add kitsas....* gnu/packages/finance.scm (kitsas): New variable. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Saku Laesvuori 2023-04-14Merge branch 'master' into core-updates....Conflicts: gnu/local.mk gnu/packages/build-tools.scm gnu/packages/certs.scm gnu/packages/check.scm gnu/packages/compression.scm gnu/packages/cups.scm gnu/packages/fontutils.scm gnu/packages/gnuzilla.scm gnu/packages/guile.scm gnu/packages/ibus.scm gnu/packages/image-processing.scm gnu/packages/linux.scm gnu/packages/music.scm gnu/packages/nss.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/qt.scm gnu/packages/ruby.scm gnu/packages/shells.scm gnu/packages/tex.scm gnu/packages/video.scm gnu/packages/vulkan.scm gnu/packages/web.scm gnu/packages/webkit.scm gnu/packages/wm.scm Maxim Cournoyer 2023-04-12gnu: electron-cash: Update to 4.2.14....* gnu/packages/finance.scm (electron-cash): Update to 4.2.14. [arguments]: Remove 'relax-requirements' phase. Guillaume Le Vaillant 2023-04-12gnu: p2pool: Update to 3.2....* gnu/packages/finance.scm (p2pool): Update to 3.2. Guillaume Le Vaillant 2023-04-12gnu: monero-gui: Update to 0.18.2.2....* gnu/packages/finance.scm (monero-gui): Update to 0.18.2.2. Guillaume Le Vaillant 2023-04-12gnu: monero: Update to 0.18.2.2....* gnu/packages/finance.scm (monero): Update to 0.18.2.2. Guillaume Le Vaillant 2023-03-27gnu: bitcoin-unlimited: Disable failing test....* gnu/packages/finance.scm (bitcoin-unlimited)[arguments]: Disable a test failing because of an expired SSL certificate. Guillaume Le Vaillant 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-06gnu: ledger: Update to 3.3.1....* gnu/packages/finance.scm (ledger): Update to 3.3.1. [source]: Remove snippet. [arguments]<#:phases>: Re-enable old test. Jelle Licht 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-03-01gnu: xmrig: Update to 6.19.0....* gnu/packages/finance.scm (xmrig): Update to 6.19.0. Guillaume Le Vaillant 2023-03-01gnu: monero-gui: Update to 0.18.2.0....* gnu/packages/finance.scm (monero-gui): Update to 0.18.2.0. Guillaume Le Vaillant 2023-03-01gnu: p2pool: Update to 3.1....* gnu/packages/finance.scm (p2pool): Update to 3.1. [arguments]: Add 'configure-flags". Add custom 'check' phase and enable tests. Guillaume Le Vaillant 2023-03-01gnu: monero: Update to 0.18.2.0....* gnu/packages/finance.scm (monero): Update to 0.18.2.0. Guillaume Le Vaillant