aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages abduco)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public abduco
  (package
   (name "abduco")
   (version "0.6")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.brain-dump.org/projects/abduco/abduco-"
                  version ".tar.gz"))
            (sha256
             (base32
              "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check)))) ; no test suite
   (synopsis "Session management in a clean and simple way")
   (description "abduco provides session management i.e. it allows programs to
be run independently from their controlling terminal.  That is, programs can
be detached---run in the background---and then later reattached.")
   (home-page "https://www.brain-dump.org/projects/abduco/")
   (license isc)))
nfigure would fail when cross-compiling with “Git is missing”. Reported by gabber on #guix. * gnu/packages/package-management.scm (guix)[arguments]: Add ‘ac_cv_path_GIT’ to #:configure-flags. Ludovic Courtès 2023-09-28gnu: guix: Update to d0438fc....This adds the “builtin:git-download” derivation builder to guix-daemon, added in commit 13b0cf85eb31e1b1ea674debbbfb0f35a32d1374. * gnu/packages/package-management.scm (guix): Update to d0438fc. Ludovic Courtès 2023-09-25gnu: guile-fibers: Remove version from latest package....As I think this makes more sense, the version is only specified when you need a specific previous release. * gnu/packages/guile-xyz.scm (guile-fibers): Rename to guile-fibers-1.0. (guile-fibers-1.3): Rename to guile-fibers. (guile-fibers-1.1): Inherit from guile-fibers. * gnu/packages/admin.scm (shepherd-0.10)[native-inputs]: Replace guile-fibers-1.3 with guile-fibers. * gnu/packages/ci.scm (cuirass)[inputs]: Likewise. * gnu/packages/gnunet.scm (gnunet-scheme)[propagated-inputs,native-inputs]: Likewise. * gnu/packages/package-management.scm (guix-build-coordinator) [inputs,propagated-inputs]: Likewise. * gnu/packages/package-management.scm (nar-herder)[inputs,propagated-inputs]: Likewise. * gnu/packages/web.scm (guix-data-service)[propagated-inputs]: Likewise. Christopher Baines 2023-09-18Revert "gnu: guix: Update to 1.4.0-11.658de25e99."...Several people on IRC report that "rewrite-url, to-version specified" fails. This reverts commit 1a0c7f71f0d74167f04377773791305260871b26. Janneke Nieuwenhuizen 2023-09-18gnu: guix: Update to 1.4.0-11.658de25e99....* gnu/packages/package-management.scm (guix): Update to 1.4.0-11.658de25e99. Janneke Nieuwenhuizen 2023-09-16gnu: bffe: Update to 0-2.722c37e....* gnu/packages/package-management.scm (bffe): Update to 0-2.722c37e. Christopher Baines 2023-09-16gnu: guix-build-coordinator: Update to 0-89.9c42dcb....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-89.9c42dcb. Christopher Baines 2023-09-15gnu: libostree: Update to 2023.5....* gnu/packages/package-management.scm (libostree): Update to 2023.5. Signed-off-by: Christopher Baines <mail@cbaines.net> kiasoc5 2023-09-15services: bffe: Use guile from the package....Rather than hardcoding a particular guile in the service definition. * gnu/services/guix.scm (bffe-shepherd-services): Use guile from the package. * gnu/packages/package-management.scm (bffe)[inputs]: Remove unnecessary guile-next input. Christopher Baines 2023-09-15gnu: Add bffe....* gnu/packages/package-management.scm (bffe): New variable. Christopher Baines 2023-09-12gnu: nar-herder: Use guile-next....As this provides suspendable soft/custom ports, which I'd like to use. * gnu/packages/package-management.scm (nar-herder)[native-inputs,inputs]: Use guile-next. Christopher Baines 2023-08-29gnu: guix-build-coordinator: Update to 0-88.cbded42....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-88.cbded42. Christopher Baines 2023-08-26gnu: guix-build-coordinator: Update to 0-87.06a4469....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-87.06a4469. Christopher Baines 2023-08-22gnu: guix: Update to 1.4.0-10.4dfdd82210....* gnu/packages/package-management.scm (guix): Update to 1.4.0-10.4dfdd82210. Janneke Nieuwenhuizen 2023-08-22gnu: guix: Disable some tests on the Hurd....* gnu/packages/package-management.scm (guix)[arguments]: When building on the Hurd, add phase disable-tests/hurd. Janneke Nieuwenhuizen 2023-08-22gnu: guix: Update to 30355c1....Fixes a test failure in 'tests/guix-system.sh' on aarch64-linux, introduced by 4cdbbfa48d87d9a500288249f228fd19d4371919. * gnu/packages/package-management.scm (guix): Update to 30355c1. Ludovic Courtès 2023-08-21gnu: guix: Update to 0e6215a....* gnu/packages/package-management.scm (guix): Update to 0e6215a. Ludovic Courtès 2023-08-12gnu: conda: Add missing dependency....*gnu/packages/package-management.scm (conda)[native-inputs]: Add PYTHON-MOCK. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Mădălin Ionel Patrașcu 2023-07-23gnu: fuse@3: Bind to default FUSE variable....* gnu/packages/linux.scm (fuse): Rename this… (fuse-2): …to this, and… (fuse-3): …rename this… (fuse): …to this! (fuse-static): Rename this… (fuse-2-static): …to this. Adjust all users. Tobias Geerinckx-Rice 2023-07-26gnu: guix-build-coordinator: Update to 0-86.f39f160....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-86.f39f160. [arguments]: Update style. Christopher Baines 2023-07-26gnu: nar-herder: Update to 0-21.53682fa....* gnu/packages/package-management.scm (nar-herder): Update to 0-21.53682fa. [arguments]: Update style. Christopher Baines 2023-07-16gnu: conan: Update to 2.0.9....* gnu/packages/package-management.scm (conan): Update to 2.0.9. [arguments]: Upgrade python-pyyaml-5 to python-pyyaml. Tobias Geerinckx-Rice 2023-07-16gnu: gcab: Remove input labels....* gnu/packages/package-management.scm (gcab)[native-inputs]: Remove input labels. Tobias Geerinckx-Rice 2023-07-16gnu: gcab: Update to 1.6....* gnu/packages/package-management.scm (gcab): Update to 1.6. Tobias Geerinckx-Rice 2023-07-11gnu: nix: Update to 2.16.1....* gnu/packages/package-management.scm (nix): Update to 2.16.1. [source]: Use HTTPS for package source. [inputs]: Add nlohmann-json. [native-inputs]: Add rapidcheck. [arguments]<#:phases>: In phase "check", change the value of environment variable "NIX_STORE" to "/nix/store" temporarily. * gnu/packages/patches/nix-dont-build-html-doc.diff: Update. Co-authored-by: jgart <jgart@dismail.de> Zhu Zihao 2023-07-01Revert "gnu: nix: Use HTTPS for package source."...This reverts commit cdb3cd4afaa37097208daef1d39d85c0f431e592. Wrong patch revision. Nicolas Goaziou 2023-07-01Revert "gnu: nix: Update to 2.16.0."...This reverts commit 554d46882bc4443dcebbba5aac70b016537d0975. Wrong patch revision. Nicolas Goaziou 2023-07-01gnu: nix: Use HTTPS for package source....* gnu/packages/package-management.scm (nix)[source]: Use HTTPS. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Zhu Zihao 2023-07-01gnu: nix: Update to 2.16.0....* gnu/packages/package-management.scm (nix): Update to 2.16.0. [inputs]: Add nlohmann-json. [native-inputs]: Add rapidcheck. [arguments]<#:phases>: In phase "check", change the value of environment variable "NIX_STORE" to "/nix/store" temporarily. * gnu/packages/patches/nix-dont-build-html-doc.diff: Update. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Zhu Zihao 2023-06-17gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?....* gnu/packages/hurd.scm (hurd-target?): Remove. (hurd-system?): Move to... * guix/utils.scm (system-hurd?): ...here. * gnu/packages/*: Update all users, removing (gnu packages hurd) include where now unused. Janneke Nieuwenhuizen 2023-06-14gnu: guile-fibers: Remove 'guile-fibers-next'....* gnu/packages/guile-xyz.scm (guile-fibers-next): Remove. * gnu/packages/package-management.scm (guix-build-coordinator)[arguments] [native-inputs, propagated-inputs]: Replace GUILE-FIBERS-NEXT by GUILE-FIBERS-1.3. (nar-herder)[arguments, native-inputs, propagated-inputs]: Likewise. * gnu/packages/web.scm (guix-data-service)[propagated-inputs]: Likewise. Ludovic Courtès 2023-06-09gnu: guix: Update to 44bbfc2....* gnu/packages/package-management.scm (guix): Update to 44bbfc2. Ludovic Courtès 2023-06-06gnu: python-anaconda-client: Fix build with Python 3.10....* gnu/packages/package-management.scm (python-anaconda-client)[build-system]: Use pyproject-bulid-system. [arguments]: Move contents of 'remove-network-tests phase to #:test-flags; drop trailing #T from 'set-HOME phase; add phase 'python3.10-compatibility; disable test_conda_root and test_conda_root_outside_root_environment. Ricardo Wurmus 2023-06-03gnu: guix-build-coordinator: Update to 0-85.c44d485....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-85.c44d485. Christopher Baines 2023-05-30gnu: nar-herder: Update to 0-20.b27ca4d....* gnu/packages/package-management.scm (nar-herder): Update to 0-20.b27ca4d. Christopher Baines 2023-05-28gnu: guix: Remove trailing #t from phases....* gnu/packages/package-management.scm (guix)[arguments]: Remove trailing #t from phases. Efraim Flashner 2023-05-28gnu: guix: Fix cross-building....* gnu/packages/package-management.scm (guix)[arguments]: In custom 'set-font-path phase also search native-inputs for the input directory. Efraim Flashner 2023-05-25gnu: guix-build-coordinator: Fix source hash....The previous commit has the wrong hash, I think I ended up building the data service instead for some reason and didn't set the hash of this package correctly. * gnu/packages/package-management.scm (guix-build-coordinator)[source]: Fix hash. Christopher Baines 2023-05-25gnu: guix-build-coordinator: Update to 0.0.1-41.6885006....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0.0.1-41.6885006. Christopher Baines 2023-05-24gnu: guix: Depend on 'graphviz-minimal'....* gnu/packages/package-management.scm (guix)[arguments]: Add 'set-font-path' phase. [native-inputs]: Change GRAPHVIZ to GRAPHVIZ-MINIMAL. Add FONT-GHOSTSCRIPT. (guix-daemon)[native-inputs]: Remove "font-ghostscript". [arguments]: Delete 'set-font-path' phase. Ludovic Courtès 2023-05-23gnu: nar-herder: Update to 0-19.efaf8fa....* gnu/packages/package-management.scm (nar-herder): Update to 0-19.efaf8fa. Christopher Baines 2023-05-23gnu: guix-build-coordinator: Update to 0-83.c79f455....* gnu/packages/package-management.scm (guix-build-coordinator): Update to 0-83.c79f455. Christopher Baines