aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages abduco)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public abduco
  (package
   (name "abduco")
   (version "0.6")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.brain-dump.org/projects/abduco/abduco-"
                  version ".tar.gz"))
            (sha256
             (base32
              "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check)))) ; no test suite
   (synopsis "Session management in a clean and simple way")
   (description "abduco provides session management i.e. it allows programs to
be run independently from their controlling terminal.  That is, programs can
be detached---run in the background---and then later reattached.")
   (home-page "https://www.brain-dump.org/projects/abduco/")
   (license isc)))
ader'>2022-10-13ci: Honor the system passed to image->job.Mathieu Othacehe Fixes: <https://issues.guix.gnu.org/53480>. * gnu/ci.scm (image->job): Pass the system argument to the underlying lower-object call. 2022-10-11Revert "guix system: Remove unused 'read-operating-system' procedure."Ludovic Courtès This reverts commit d11a432adffe9308eafec6b77cddd3145029109e. The 'read-operating-system' is used in Emacs-Guix. 2022-09-24gnu: Add compression module.Mathieu Othacehe Move the compression record to a dedicated module so that it can be used outside (guix scripts pack) module. * guix/scripts/pack.scm (<compressor>, %compressors, lookup-compressor): Move it to ... * gnu/compression.scm: ... this new file. * gnu/ci.scm: Adapt it. * local.mk (GNU_SYSTEM_MODULES): Add it. 2022-08-17ci: Fix the images specification.Mathieu Othacehe If the current-guix-package parameter is not set, Cuirass will try to update the in-store Git checkout used by the evaluate.scm inferior: ice-9/boot-9.scm:1685:16: In procedure raise-exception: ERROR: 1. &inferior-exception: arguments: (git-error #<inferior-object #<<git-error> code: -3 message: "could not find repository from '/gnu/store/v33m82qzkvd96dlp2g83dvz62n4pkad2-guix-20d8081'" class: 6>>) inferior: #<inferior pipe (0 1 1) 7f7948957dc0> stack: ((#f ("ice-9/boot-9.scm" 1779 13)) (raise-exception ("ice-9/boot-9.scm" 1682 16)) (raise-exception ("ice-9/boot-9.scm" 1684 16)) (#f ("guix/git.scm" 395 13)) This is a follow-up of: 5bce4c82422de6beb3ce6120ba1592be898c2b72. * gnu/ci.scm (image-jobs): Add source and commit arguments. Use them to set the current-guix-package parameter. (cuirass-jobs): Adapt accordingly. 2022-08-09build-system: Add 'channel-build-system'.Ludovic Courtès * gnu/ci.scm (channel-build-system, channel-source->package): Remove. * gnu/packages/package-management.scm (channel-source->package): New procedure, moved from (gnu ci). * guix/build-system/channel.scm: New file, with code moved from (gnu ci). * doc/guix.texi (Build Systems): Document it. 2022-08-05guix system: Remove unused 'read-operating-system' procedure.Ludovic Courtès * guix/scripts/system.scm (read-operating-system): Remove. * gnu/ci.scm: Remove unused (guix scripts system) import. 2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/.Josselin Poiret * gnu/platform.scm: * gnu/platforms/arm.scm: * gnu/platforms/hurd.scm: * gnu/platforms/mips.scm: * gnu/platforms/powerpc.scm: * gnu/platforms/riscv.scm: * gnu/platforms/s390.scm: * gnu/platforms/x86.scm: Move to guix/. * Makefile.am: * doc/guix.texi (Porting to a New Platform): * etc/release-manifest.scm: * gnu/ci.scm: * gnu/image.scm: * gnu/local.mk: * gnu/packages/bioinformatics.scm: * gnu/packages/bootstrap.scm: * gnu/packages/cross-base.scm: * gnu/packages/instrumentation.scm: * gnu/packages/linux.scm: * gnu/system/image.scm: * gnu/system/images/hurd.scm: * gnu/system/images/novena.scm: * gnu/system/images/pine64.scm: * gnu/system/images/pinebook-pro.scm: * gnu/system/images/rock64.scm: * guix/scripts/build.scm: * guix/scripts/system.scm: * guix/self.scm: Update (gnu platform...) to (guix platform...). Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-05-22ci: Do not rely on hardcoded cross-targets lists.Mathieu Othacehe * gnu/ci.scm (%cross-targets): Remove it ... (cross-jobs): ... and use the targets procedure instead. * etc/release-manifest.scm: Adapt it. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> 2022-01-01ci: Add extra jobs for tunable packages.Ludovic Courtès This allows us to provide substitutes for tuned package variants. * gnu/ci.scm (package-job): Add #:suffix and honor it. (package->job): Add #:suffix and honor it. (%x86-64-micro-architectures): New variable. (tuned-package-jobs): New procedure. (cuirass-jobs): Add jobs for tunable packages. 2021-12-10Merge remote-tracking branch 'signed/master' into core-updatesMathieu Othacehe 2021-12-06ci: Cross-build the 'guix' package.Ludovic Courtès * gnu/ci.scm (%core-packages): Add GUIX. 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-04ci: Allow manifests to contain any lowerable object.Ludovic Courtès Previously, manifests could only contain packages: https://lists.gnu.org/archive/html/guix-devel/2021-10/msg00002.html This allows us to pass origins as found in 'etc/source-manifest.scm'. * gnu/ci.scm (derivation->job): Change default #:timeout value to 5h. (manifests->packages): Remove. (manifests->jobs): New procedure. (cuirass-jobs): Use it in the 'manifests' case. 2021-09-27ci: Adjust 'channel-build-system' to monadic style.Ludovic Courtès * gnu/ci.scm (channel-build-system): Adjust to new monadic style. 2021-07-10ci: Build commencement packages supported on the target system.Ludovic Courtès This is a followup to df49fe2a13d933c640e3189413c5adfced1103c5. * gnu/ci.scm (%bootstrap-packages): Rename to... (commencement-packages): ... this, and turn into a procedure. Filter packages that pass 'supported-package?'. (cuirass-jobs): Adjust accordingly. 2021-07-09ci: Add bootstrap packages to the core subset.Mathieu Othacehe * gnu/ci.scm (%bootstrap-packages): New variable. (cuirass-jobs): Add it to the core subset. 2021-07-09ci: Add bootstrap packages to the core subset.Mathieu Othacehe * gnu/ci.scm (%bootstrap-packages): New variable. (cuirass-jobs): Add it to the core subset. 2021-07-05ci: Change "core" subset to include the latest GCC and Guile.Ludovic Courtès * gnu/ci.scm (%core-packages): Replace GCC-7 by GCC-11 and GUILE-2.0 by GUILE-3.0. 2021-07-03ci: Remove duplicate ".SYSTEM" extension for cross-compilation jobs.Ludovic Courtès * gnu/ci.scm (package-cross-job): Remove ".SYSTEM". 2021-05-25ci: Add derivation inputs.Mathieu Othacehe * gnu/ci.scm (derivation->job): Add the derivation inputs to the job association list. 2021-05-25ci: Add derivation inputs.Mathieu Othacehe * gnu/ci.scm (derivation->job): Add the derivation inputs to the job association list. 2021-04-28ci: Add custom subset.Mathieu Othacehe * gnu/ci.scm (cuirass-jobs): Add 'custom susbset. 2021-04-28ci: Add arguments->systems procedure.Mathieu Othacehe * gnu/ci.scm (arguments->systems): New procedure. (cuirass-jobs): Use it. 2021-04-28ci: Factorize image->job procedure.Mathieu Othacehe * gnu/ci.scm (image-jobs): Extract ->job procedure into ... (image->job): ... this new procedure. 2021-04-18ci: tarball: Use "current-guix" as profile name.Mathieu Othacehe Fixes: <https://issues.guix.gnu.org/47841>. * gnu/ci.scm (tarball-jobs): Use "current-guix" as profile name. 2021-04-12ci: Fix system-tests subset.Mathieu Othacehe * gnu/ci.scm (system-test-jobs): Make sure that "all-system-tests" is also covered by the "current-guix-package" parameter. 2021-04-08ci: Introduce new subsets.Mathieu Othacehe Introduce 'images, 'system-tests and 'tarball subsets. * gnu/ci.scm (cuirass-jobs): Break the 'all subset into smaller subsets. 2021-04-08ci: Remove the job period argument.Mathieu Othacehe Cuirass now deals with periodicity directly on specifications. * gnu/ci.scm (derivation->job): Remove the period argument. (image-jobs, system-test-jobs, tarball-jobs): Adapt them.