;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2022 Hartmut Goebel ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (test-hexpm) #:use-module (guix import hexpm) #:use-module (guix base32) #:use-module (gcrypt hash) #:use-module (guix tests) #:use-module (srfi srfi-64) #:use-module (ice-9 binary-ports) #:use-module (ice-9 match)) (define test-bla-package "{\"name\": \"bla\", \"html_url\": \"https://hex.pm/packages/bla\", \"docs_html_url\": null, \"meta\": { \"description\": \"A cool package\", \"licenses\": [\"MIT\", \"Apache-2.0\"] }, \"releases\": [ {\"url\": \"https://hex.pm/api/packages/bla/releases/1.5.0\", \"version\": \"1.5.0\"}, {\"url\": \"https://hex.pm/api/packages/bla/releases/1.4.7\", \"version\": \"1.4.7\"} ] }") (define test-bla-release "{ \"version\": \"1.5.0\", \"url\": \"https://hex.pm/api/packages/bla/releases/1.5.0\", \"requirements\": { \"blubb\":{\"app\": \"blubb\", \"optional\": false, \"requirement\": \"~>0.3\" }, \"fasel\":{\"app\": \"fasel\", \"optional\": false, \"requirement\": \"~>1.0\" } }, \"meta\":{ \"build_tools\":[\"mix\", \"make\", \"rebar3\"
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages abduco)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public abduco
  (package
   (name "abduco")
   (version "0.6")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.brain-dump.org/projects/abduco/abduco-"
                  version ".tar.gz"))
            (sha256
             (base32
              "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check)))) ; no test suite
   (synopsis "Session management in a clean and simple way")
   (description "abduco provides session management i.e. it allows programs to
be run independently from their controlling terminal.  That is, programs can
be detached---run in the background---and then later reattached.")
   (home-page "https://www.brain-dump.org/projects/abduco/")
   (license isc)))
(`(package (name "erlang-bla") (version "1.5.0") (source (origin (method url-fetch) (uri (hexpm-uri "bla" version)) (sha256 (base32 "0zcl4dgcmqwl1g5xb901pd6dz61r1xgmac9mqlwvh022paa6gks1")))) (build-system rebar-build-system) (inputs (list erlang-blubb erlang-fasel)) (synopsis "A cool package") (description "This package provides a cool package") (home-page "https://hex.pm/packages/bla") (license (list license:expat license:asl2.0))) #t) (x (pk 'fail x #f)))))) (test-assert "hexpm-recursive-import" ;; Replace network resources with sample data. (mock ((guix http-client) http-fetch (lambda (url . rest) (match url ("https://hex.pm/api/packages/bla" (values (open-input-string test-bla-package) (string-length test-bla-package))) ("https://hex.pm/api/packages/bla/releases/1.5.0" (values (open-input-string test-bla-release) (string-length test-bla-release))) ("https://hex.pm/api/packages/blubb" (values (open-input-string test-blubb-package) (string-length test-blubb-package))) ("https://hex.pm/api/packages/blubb/releases/0.3.1" (values (open-input-string test-blubb-release) (string-length test-blubb-release))) ("https://hex.pm/api/packages/fasel" (values (open-input-string test-fasel-package) (string-length test-fasel-package))) ("https://hex.pm/api/packages/fasel/releases/1.2.1" (values (open-input-string test-fasel-release) (string-length test-fasel-release))) (_ (error "http-fetch got unexpected URL: " url))))) (mock ((guix build download) url-fetch (lambda* (url file-name #:key (mirrors '()) verify-certificate?) (with-output-to-file file-name (lambda () (display (match url ("https://repo.hex.pm/tarballs/bla-1.5.0.tar" "bla-source") ("https://repo.hex.pm/tarballs/blubb-0.3.1.tar" "blubb-source") ("https://repo.hex.pm/tarballs/fasel-1.2.1.tar" "fasel-source") (_ (error "url-fetch got unexpected URL: " url)))))))) (match (hexpm-recursive-import "bla") (`((package (name "erlang-blubb") (version "0.3.1") (source (origin (method url-fetch) (uri (hexpm-uri "blubb" version)) (sha256 (base32 "17y88b5y8ld7s1c2bcwwwa04pf1cl4402i9zk3inna221ps3ppj2")))) (build-system mix-build-system) (inputs (list erlang-fasel)) (synopsis "Another cool package") (description "Another cool package") (home-page "https://hex.pm/packages/blubb") (license license:expat)) (package (name "erlang-fasel") (version "1.2.1") (source (origin (method url-fetch) (uri (hexpm-uri "fasel" version)) (sha256 (base32 "1k6d70mxwqgq78jrbr7yqnw187yki74jnagybi7nacrj4a67qjha")))) (build-system gnu-build-system) (synopsis "Yet another cool package") (description "Yet another cool package") (home-page "https://hex.pm/packages/fasel") (license "GPL")) (package (name "erlang-bla") (version "1.5.0") (source (origin (method url-fetch) (uri (hexpm-uri "bla" version)) (sha256 (base32 "0d3gj746c4swbb1m6ycylxb239jsavvdcizag6bfbg2aqccxwij8")))) (build-system rebar-build-system) (inputs (list erlang-blubb erlang-fasel)) (synopsis "A cool package") (description "This package provides a cool package") (home-page "https://hex.pm/packages/bla") (license (list license:expat license:asl2.0)))) #t) (x (pk 'fail x #f)))))) (test-end "hexpm")