aboutsummaryrefslogtreecommitdiff
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.

(define-module (gnu packages abduco)
  #:use-module (guix build-system gnu)
  #:use-module (guix utils)
  #:use-module (guix download)
  #:use-module (guix licenses)
  #:use-module (guix packages))

(define-public abduco
  (package
   (name "abduco")
   (version "0.6")
   (source (origin
            (method url-fetch)
            (uri (string-append
                  "https://www.brain-dump.org/projects/abduco/abduco-"
                  version ".tar.gz"))
            (sha256
             (base32
              "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
   (build-system gnu-build-system)
   (arguments
    `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
                         (string-append "PREFIX=" (assoc-ref %outputs "out")))
      #:phases (modify-phases %standard-phases
                 (delete 'configure)
                 (delete 'check)))) ; no test suite
   (synopsis "Session management in a clean and simple way")
   (description "abduco provides session management i.e. it allows programs to
be run independently from their controlling terminal.  That is, programs can
be detached---run in the background---and then later reattached.")
   (home-page "https://www.brain-dump.org/projects/abduco/")
   (license isc)))
tk-xwidgets): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> Antero Mejr 2023-04-30gnu: emacs: Use librsvg-for-system....* gnu/packages/emacs.scm (emacs)[inputs]: Replace librsvg input logic with librsvg-for-system. Efraim Flashner 2023-04-19gnu: emacs-next: Update to 29.0.90....* gnu/packages/emacs.scm (emacs-next): Update to 29.0.90. Liliana Marie Prikler 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-17gnu: m17n-lib: Fix cross-compile....* gnu/packages/emacs.scm (m17n-lib) [source]: Add m17n-lib-1.8.0-use-pkg-config-for-freetype.patch. [native-inputs]: When cross-compile add pkg-config, libtool, gettext-minimal, autoconf, automake. [arguments]: When cross-compile, add phase to fix rpl_malloc undefined references. * gnu/packages/patches/m17n-lib-1.8.0-use-pkg-config-for-freetype.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Z572 2023-03-17gnu: m17n-db: Fix cross-compile....* gnu/packages/emacs.scm (m17n-db) [inputs]: Move gettext-minimal to ... [native-inputs]: ... here. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Z572 2023-03-12gnu: emacs-next-pgtk: Inherit from emacs-next-tree-sitter....Inherit pgtk emacs from tree-sitter to have both features available for wayland users. For more details: https://yhetil.org/guix-devel/87r0txr99u.fsf@inventati.org/T/#u * gnu/packages/emacs.scm (emacs-next-pgtk): Inherit from emacs-next-tree-sitter. Andrew Tropin 2023-03-12gnu: emacs-next-tree-sitter: Inherit from emacs-next....Make tree-sitter emacs available without pgtk. It's part of ongoing iheritance hierarchy update, tree-sitter have less implications than pgtk and thus it should be placed earlier in inheritance chain. For more details: https://yhetil.org/guix-devel/87r0txr99u.fsf@inventati.org/T/#u * gnu/packages/emacs.scm (emacs-next-tree-sitter): Inherit from emacs-next. Andrew Tropin 2023-03-09gnu: emacs-next-tree-sitter: Inherit from emacs-next-pgtk....Make emacs with tree-sitter work on wayland as well. * gnu/packages/emacs.scm (emacs-next-tree-sitter): Inherit from emacs-next-pgtk, remove uneeded native-inputs, add synopsis and description. [source]: Use inherited patches. Andrew Tropin 2023-03-09gnu: emacs-next-pgtk: Remove xwidgets support....xwidgets is beefy and buggy, but emacs-next-pgtk is important for wayland users, so it seems a good idea to remove xwidgets from emacs-next-pgtk. Also, we have a separate emacs-xwidgets package for those who wants to experiment. * gnu/packages/emacs.scm (emacs-next-pgtk)[propagated-inputs]: Remove gsettings-desktop-schemas glib-networking. [arguments]<#:configure-flags>: Remove --with-xwidgets. [inputs]: Remove webkitgtk-with-libsoup2. [home-page]: PGTK is merged to upstream emacs repository now, so inherit home-page from emacs-next. Andrew Tropin 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-03-01gnu: Add emacs-motif....* gnu/packages/text-editors.scm (emacs-motif): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net> Andy Tai 2023-02-26gnu: emacs-next: Update to 29.0.60-1.f1f571e....* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-1.f1f571e. Liliana Marie Prikler 2023-02-26gnu: Add emacs-next-tree-sitter....* gnu/packages/emacs.scm (emacs-next-tree-sitter): New variable. (emacs-next): Remove tree sitter support. Liliana Marie Prikler 2023-02-12gnu: Remove tree-sitter comment from emacs.scm imports....* gnu/packages/emacs.scm: Remove tree-sitter comment. Signed-off-by: Andrew Tropin <andrew@trop.in> Pierre Langlois 2023-02-11gnu: emacs: Add TREE_SITTER_GRAMMAR_PATH support....gnu/packages/emacs.scm (emacs)[native-search-paths]: Add a search-path for tree-sitter grammars. gnu/packages/aux-files/emacs/guix-emacs.el: Add directories from TREE_SITTER_GRAMMAR_PATH to treesit-extra-load-path. Andrew Tropin 2023-02-09gnu: tree-sitter: Move to its own module....* gnu/packages/text-editors.scm (tree-sitter): Move to ... * gnu/packages/tree-sitter.scm: ... here, a new module. * gnu/packages/vim.scm: Use (gnu packages tree-sitter). * gnu/packages/emacs.scm: Use (gnu packages tree-sitter). * gnu/local.mk (GNU_SYSTEM_MODULES): Register tree-sitter.scm new module. Signed-off-by: Andrew Tropin <andrew@trop.in> Pierre Langlois 2023-02-04gnu: emacs-next: Enable tree-sitter support....* gnu/packages/emacs.scm (emacs-next): Update to 29.0.60-0.ac7ec87. * gnu/packages/emacs.scm (emacs-next)[inputs]: Add tree-sitter. Signed-off-by: Andrew Tropin <andrew@trop.in> Declan Tsien 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2023-01-26gnu: emacs-next: Update to 29.0.50-4.6adc193....* gnu/packages/emacs.scm (emacs-next): Update to 29.0.50-4.6adc193. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Fredrik Salomonsson 2023-01-22gnu: emacs-minimal: Do not patch compilation driver....The ‘patch-compilation-driver’ phase pulls in libgccjit even though it has been deliberately removed from emacs-minimal. * gnu/packages/emacs.scm (emacs)[#:phases]: Delete ‘patch-compilation-driver’. Liliana Marie Prikler 2022-11-03gnu: emacs-next: Update to 29.0.50-3.22e8a77....* gnu/packages/emacs.scm (emacs-next): Update to 29.0.50-3.22e8a77. Signed-off-by: Christopher Baines <mail@cbaines.net> jgart 2022-10-16gnu: emacs: Update to 28.2....* gnu/packages/emacs.scm (emacs): Update to 28.2. Liliana Marie Prikler 2022-10-16Merge branch 'staging'Marius Bakke 2022-10-15gnu: emacs-next: Update to 29.0.50-2.4aeb80c....* gnu/packages/patches/emacs-native-comp-driver-options.patch: New file. * gnu/local.mk: Register it here. * gnu/packages/emacs.scm (emacs-next): Update to 29.0.50-2.4aeb80c. Liliana Marie Prikler 2022-10-02gnu: emacs-minimal: Reduce to minimal inputs....This partly reverts dbcba75c0e96d8eb2b0bf9dbb3a49d15b38f80d2. In that commit, emacs-minimal gained a few inputs that weren't actually used as native compilation is disabled. Discovered by djeis in IRC, see also <http://logs.guix.gnu.org/guix/2022-10-02.log#170047>. * gnu/packages/emacs.scm (emacs-minimal)[inputs]: Remove ld-wrapper, binutils, glibc, libgccjit, and zlib. [arguments]<#:phases>: Delete ‘set-libgccjit-path’. Liliana Marie Prikler 2022-09-27Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cran.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/icu4c.scm gnu/packages/java.scm gnu/packages/machine-learning.scm gnu/packages/tex.scm Maxim Cournoyer 2022-09-19gnu: emacs-next-pgtk: Inherit patches from emacs-next....* gnu/packages/emacs.scm (emacs-next-pgtk)[source]: Inherit patches from emacs-next. Andrew Tropin 2022-09-18Merge branch 'staging' into core-updatesMarius Bakke 2022-09-16gnu: emacs-next-pgtk: Fix super key problem....Recent version of emacs 29 with pgtk flag has a problem with handling super key modifier, due to gtk bug: https://gitlab.gnome.org/GNOME/gtk/-/issues/4913 This commit workarounds it. * gnu/packages/patches/emacs-pgtk-super-key-fix.patch: New file. * gnu/packages/emacs.scm (emacs-next-pgtk): Use it here. * gnu/local.mk (dist_patch_DATA): Register it here. Andrew Tropin 2022-09-15Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cmake.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/sdl.scm pango-next, vala-next and librsvg-bootstrap were removed in the process. Maxim Cournoyer 2022-09-11gnu: emacs: Build with native compilation....* gnu/packages/emacs.scm (%emacs-modules): New variable. (emacs)[arguments]<#:modules>: Use it here. <#:configure-flags> Add “--with-native-compilation”. <#:make-flags>: Add “NATIVE_FULL_AOT=1”. <#:phases>: Add ‘set-libgccjit-path’ and ‘patch-compilation-driver’. [inputs]: Add explicit ld-wrapper, binutils, glibc, and libgccjit. [search-paths]: Add EMACSNATIVELOADPATH. (emacs-minimal, emacs-xwidgets, emacs-no-x) (emacs-no-x-toolkit): Adjust accordingly. Liliana Marie Prikler