summaryrefslogtreecommitdiff
path: root/ctftilde/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ctftilde/Makefile.am')
-rw-r--r--ctftilde/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/ctftilde/Makefile.am b/ctftilde/Makefile.am
new file mode 100644
index 0000000..99d7ddd
--- /dev/null
+++ b/ctftilde/Makefile.am
@@ -0,0 +1,27 @@
+# SPDX-License-Identifier: CC0-1.0
+#
+# Copyright (C) 2023, 2024 Wojtek Kosior <koszko@koszko.org>
+
+SUBDIRS = src/guile src/resources
+
+dist_bin_SCRIPTS = scripts/ctftilde
+
+.PHONY: guile-objects
+guile-objects:
+ $(MAKE) --directory src/guile
+
+EXTRA_DIST = \
+ guix-devshell \
+ bootstrap \
+ gen-config-scm
+# LICENSES/CC0-1.0.txt \
+# LICENSES/GPL-3.0-or-later.txt \
+# .reuse/dep5 \
+# .dir-locals.el \
+# .gitignore \
+# README.md.license
+
+MAKEFILE_INS = \
+ Makefile.in \
+ src/guile/Makefile.in \
+ src/resources/Makefile.in